I don't know exactly what the problem is, in phpstorm, or gnome-shell, because writing here.

gnome-shell freezes, when I working in PHPStorm. But freeze staring after click on any buttons in phpstorm's popup windows(creating folder, checking todo list, review.., etc), like this:

phpstorm popup window

mouse can moving but nothing clickable.

gnome-shell process loads one logical kernel 100% and don't unfreezes.

after this I kill gnome-shell process (Ctrl+Alt+Backspace or through virtual terminal Ctrl+Alt+F3), login and run programs again..

Initially, after upgrading to 19.04 this problem was not, it appeared after 2-3 months.

Now, this problem happens only with working in phpstorm

I have:

  • GPU: GeForce GTX 1050 Ti
  • OS: Ubuntu 19.04 disco
  • Kernel: x86_64 Linux 5.0.0-22-generic
  • GNOME Shell 3.32.2
  • PHPStorm 2019.2(2019.1)

I tried:

  • set default gnome theme
  • disable all user gnome-extensions
  • disable all plugins on phpstorm
  • set default theme on phpstorm
  • reinstall gnome-shell like: sudo apt-get install --reinstall gnome-shell
  • reinstall phpstorm
  • change nvidia drivers(390 proprietary, 430 open source, xorg, 418 proprietary)
  • I am seeing the exact same issue, though with other Jetbrains programs. Datagrip and Rider are both triggering the same gnome-shell freeze. Excruciatingly annoying. – John Sloper Jul 31 '19 at 11:48

I've had the same issue. I've fixed it literally 5mins ago after searching another day for a fix ;)

I've removed vmoptions file from ../config dir. Try this maybe this will help You.

  • Thanks! but in what certainly directory is the file located? I installed phpstorm by snap and see .vmoptions files only in /snap/phpstorm/109/bin/ directory.. – Eugene Kramorev Aug 3 '19 at 7:32
  • Okey, I find phpstorm64.vmoptions file in ~/.PhpStorm2019.2/config/ directory. I tried to remove this, aaand the problem don't solved :( but I noticed, that I can create folder, copy files. But problem happens, after popup with code review(when committing) has opened – Eugene Kramorev Aug 3 '19 at 8:53
  • I've also reinstalled phpstorm from snap: 1. remove phpstorm 2. install phpstorm 3. Open phpstorm, and import settings from last profile 4. Close phpstorm 5. remove vmoptions file 6. open phpstorm I've had problems with VCS windows, update, commit etc. now it's gone. – RT_ Aug 4 '19 at 8:27
  • I've tried this now, but it's don't help me.. – Eugene Kramorev Aug 4 '19 at 17:27
  • 1) remove phpstorm snap remove phpstorm 2) remove all settings ~/snap/phpstorm ~/.Phpstorm2019.2/ 3) snap forget [snap phpstorm id] 4) snap install phpstorm 5) create new projects 6) close phpstorm 7) remove phpstorm64.vmoptions file 8) open phpstorm and freeze with VCS windows again :( Thanks for help, anyway – Eugene Kramorev Aug 4 '19 at 17:34

I fixed it with the commands found here

On Ubuntu 19.04 run the following command to fix it (downgrading):

sudo apt install \
    gir1.2-mutter-4=3.32.0+git20190410-1ubuntu1 \
    libmutter-4-0=3.32.0+git20190410-1ubuntu1 \
    mutter=3.32.0+git20190410-1ubuntu1 \

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.