0

I'd gone through this question but dirmngr isn't getting installed as i can't install dirmngr i am not able to install updates or upgrade my kali.

ERROR: E: Failed to fetch http://http.kali.org/kali/pool/main/g/gnupg2/gpgsm_2.2.1-4_amd64.deb 404 Not Found . . . . E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

help me !

hey @Freddy have a look at this msgs

root@kali:~/Downloads# dpkg -i ./gpgsm_2.2.12-1_amd64.deb
Selecting previously unselected package gpgsm.
(Reading database ... 305519 files and directories currently installed.)
Preparing to unpack ./gpgsm_2.2.12-1_amd64.deb ...
Unpacking gpgsm (2.2.12-1) ...
dpkg: dependency problems prevent configuration of gpgsm:
 gpgsm depends on gpgconf (= 2.2.12-1); however:
  Package gpgconf is not installed.
 gpgsm depends on libc6 (>= 2.25); however:
  Version of libc6:amd64 on system is 2.24-9.
 gpgsm depends on libgcrypt20 (>= 1.8.0); however:
  Version of libgcrypt20:amd64 on system is 1.7.6-1.

dpkg: error processing package gpgsm (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 gpgsm
root@kali:~/Downloads# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  gpgsm
0 upgraded, 0 newly installed, 1 to remove and 1552 not upgraded.
1 not fully installed or removed.
After this operation, 929 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 305526 files and directories currently installed.)
Removing gpgsm (2.2.12-1) ...
Processing triggers for man-db (2.7.6.1-2) ...

and also my version is

root@kali:~/Downloads# uname -a
Linux kali 4.9.0-kali3-amd64 #1 SMP Debian 4.9.18-1kali1 (2017-04-04) x86_64 GNU/Linux
0

You probably have an outdated package index. Two newer versions of gpgsm for amd64 are present in the repository:

and

Try it again with:

sudo apt-get update
sudo apt-get install dirmngr
  • but what to do after downloading them can you guide me a little bit – Rahul Gupta Jul 30 at 6:42
  • hey @Freddy thnx for the answer but when i tried to install the packages which u told to download aren't getting installed see the msgs in my Qeustion – Rahul Gupta Jul 30 at 7:20
  • Freddy didn’t tell you to download the files, he told you to run apt-get update and apt-get install dirmngr. – Stephen Kitt Jul 30 at 9:03
  • @StephenKitt those things i had already tried but didn't worked for me. can u help me in other way. i have listed all the things in my question. – Rahul Gupta Jul 31 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.