0

Every day when I have a scheduled backup running, I see this error:

Error processing remote manifest (duplicity-inc.20190724T191929Z.to.20190726T191408Z.manifest.gpg): GPG Failed, see log below:
===== Begin GnuPG log =====
gpg: WARNING: "--no-use-agent" is an obsolete option - it has no effect
gpg: AES encrypted data
gpg: encrypted with 1 passphrase
gpg: decryption failed: Bad session key
===== End GnuPG log =====

How can I resolve this?

  • essentially that says wrong passphrase provided. are you sure the passphrase you gave is correct? did you maybe change your gpg version inbetween? ..ede/duply.net – ede Jul 30 '19 at 16:01
  • It's possible I typed my passphrase wrong. But how can I give another one? – Jonathan Jul 30 '19 at 18:14
  • seems to be not trivial. read here askubuntu.com/questions/109095/… – ede Jul 31 '19 at 7:34
1

just remembered. most likely a gpg upgrade issue, see https://askubuntu.com/questions/1057627/duplicity-fails-with-bad-session-key-error

quoting from linked workaround in the above ticket

" The problem is, like the linked post stated, that gpg 2.1 retires passphrase from pipe for key auth. The gpg agents needs to be enabled and configured for the restore to work.

Add the following to ~/.gnupg/gpg.conf:

use-agent
pinentry-mode loopback

And to your ~/.gnupg/gpg-agent.conf:

allow-loopback-pinentry

"

..ede/duply.net

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.