0

I have tried various solutions I saw but I just can't seem to solve this problem. I recently installed Elementary OS and the wifi option does not appear. The wifi chip is a Realtek r8169 chip.

This is what I get when I run sudo lshw -C network

*-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eno1
       version: 15
       serial: ac:e2:d3:d1:03:da
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:16 ioport:4000(size=256) memory:b1104000-b1104fff memory:b1100000-b1103fff
  *-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:b1000000-b100ffff
  *-network
       description: Ethernet interface
       physical id: 3
       logical name: enx0c5b8f279a64
       serial: 0c:5b:8f:27:9a:64
       capabilities: ethernet physical
       configuration: broadcast=yes driver=cdc_ether driverversion=22-Aug-2005 firmware=CDC Ethernet Device ip=192.168.8.100 link=yes multicast=yes

I even tried using ndiswrapper to install windows driver but that doesnt work.

There is an iwlwifi.conf file in /etc/modprobe.d/ I'm not really sure why it's there but shouldn't it be realtek related?.

0

Ndis works best with XP drivers (in fact it was designed according to XP) and to make it work, you need to "blacklist" the linux drivers to avoid confusion.

That file is for setting parameters. You can type "options" and say, disable powersaving to avoid connection drops or so..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.