1

I cannot seem to install any package at the app at the moment, it seems like the packages required for those apps to install are bad, I have searched and tried some solutions but those same packages still throw errors when i try them.

These are the lines when i run sudo dpkg --configure -a:

 sudo dpkg --configure -a
Setting up python-apt-common (1.6.4+elementary6~ubuntu5.0.1) ...
Setting up libgs9-common (9.26~dfsg+0-0ubuntu0.18.04.9) ...
Setting up imagemagick-6-common (8:6.9.7.4+dfsg-16ubuntu6.7) ...
Installing new version of config file /etc/ImageMagick-6/policy.xml ...
Setting up libglvnd0:amd64 (1.0.0-2ubuntu2.3) ...
Setting up gnome-settings-daemon-schemas (3.28.1-0ubuntu1.3+elementary4~ubuntu5.0.1) ...
Setting up libisc169:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up libapt-inst2.0:amd64 (1.6.11) ...
Setting up libnss-systemd:amd64 (237-3ubuntu10.24) ...
Setting up keyboard-configuration (1.178ubuntu2.9) ...
Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Setting up libwbclient0:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.11) ...
Setting up libisccc160:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up xserver-common (2:1.19.6-1ubuntu4.3) ...
Setting up cups-server-common (2.2.7-1ubuntu2.6) ...
Setting up language-pack-pl (1:18.04+20190718) ...
Setting up elementary-theme (5.2.4+r954+pkg322~daily~ubuntu5.0.1) ...
Setting up libllvm8:amd64 (1:8-3~ubuntu18.04.1) ...
Setting up nautilus-data (1:3.26.4-0~ubuntu18.04.4) ...
Setting up ppp (2.4.7-2+2ubuntu1.1) ...
Setting up psmisc (23.1-1ubuntu0.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Setting up ureadahead (0.100.0-21) ...
Setting up language-pack-nl (1:18.04+20190117) ...
Setting up xxd (2:8.0.1453-1ubuntu1.1) ...
Setting up libpng16-16:amd64 (1.6.34-1ubuntu0.18.04.2) ...
Setting up isc-dhcp-common (4.3.5-3ubuntu7.1) ...
Setting up libgtk-3-common (3.22.30-1ubuntu4) ...
Setting up libldap-common (2.4.45+dfsg-1ubuntu1.2) ...
Setting up libarchive13:amd64 (3.2.2-3.1ubuntu0.3) ...
Setting up apt-utils (1.6.11) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up debconf-i18n (1.5.66ubuntu1) ...
Setting up libgranite-common (5.2.4+r1403+pkg108~ubuntu5.0.1) ...
Setting up libisc-export169:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up libnuma1:amd64 (2.0.11-2.1ubuntu0.1) ...
Setting up cups-common (2.2.7-1ubuntu2.6) ...
Setting up tzdata (2019b-0ubuntu0.18.04) ...

Current default time zone: 'Africa/Lagos'
Local time is now:      Sun Jul 28 16:00:35 WAT 2019.
Universal Time is now:  Sun Jul 28 15:00:35 UTC 2019.
Run 'dpkg-reconfigure tzdata' if you wish to change it.

Setting up fonts-noto-color-emoji (0~20180810-0ubuntu1) ...
Setting up language-pack-ja (1:18.04+20190718) ...
Setting up systemd-sysv (237-3ubuntu10.24) ...
Setting up libelf1:amd64 (0.170-0.4ubuntu0.1) ...
Setting up mutter-common (3.28.4-0ubuntu18.04.1+elementary4~ubuntu5.0.1) ...
Setting up gpgconf (2.2.4-1ubuntu1.2) ...
Setting up evolution-data-server-common (3.28.5-0ubuntu0.18.04.2) ...
Setting up libglib2.0-0:amd64 (2.56.4-0ubuntu0.18.04.4) ...
Setting up libasound2-data (1.1.3-5ubuntu0.2) ...
Setting up libwayland-client0:amd64 (1.16.0-1ubuntu1.1~18.04.1) ...
Setting up language-pack-fr (1:18.04+20190718) ...
Setting up mount (2.31.1-0.4ubuntu3.3) ...
Setting up gpg-agent (2.2.4-1ubuntu1.2) ...
Setting up distro-info-data (0.37ubuntu0.5) ...
Setting up libtiff5:amd64 (4.0.9-5ubuntu0.2) ...
Setting up gettext-base (0.19.8.1-6ubuntu0.3) ...
Setting up libgweather-common (3.28.2-1~ubuntu18.04.1) ...
Setting up libu2f-udev (1.1.4-1ubuntu0.1) ...
Setting up libglapi-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.2) ...
Setting up libpackagekit-glib2-18:amd64 (1.1.9-1ubuntu2.18.04.5) ...
Setting up libdevmapper1.02.1:amd64 (2:1.02.145-4.1ubuntu3.18.04.1) ...
Setting up perl-modules-5.26 (5.26.1-6ubuntu0.3) ...
Processing triggers for gnome-icon-theme (3.12.0-3) ...
Setting up pantheon (1.466+r530~daily~ubuntu5.0.1) ...
Setting up fonts-noto-cjk (1:20190409+repack1-0ubuntu0.18.04) ...
Setting up libkrb5support0:amd64 (1.16-2ubuntu0.1) ...
Setting up libkmod2:amd64 (24-1ubuntu3.2) ...
Setting up language-pack-gnome-ja (1:18.04+20190718) ...
Setting up gstreamer1.0-tools (1.14.4-1~ubuntu18.04.1) ...
Setting up libmagic-mgc (1:5.32-2ubuntu0.2) ...
Setting up gnupg-l10n (2.2.4-1ubuntu1.2) ...
Setting up libasound2:amd64 (1.1.3-5ubuntu0.2) ...
Setting up evince-common (3.28.4-0ubuntu1.2+elementary2~ubuntu5.0.1) ...
Setting up bzip2 (1.0.6-8.1ubuntu0.2) ...
Setting up uuid-runtime (2.31.1-0.4ubuntu3.3) ...
Setting up libmagic1:amd64 (1:5.32-2ubuntu0.2) ...
Setting up libdrm-common (2.4.97-1ubuntu1~18.04.1) ...
Setting up libsane-common (1.0.27-1~experimental3ubuntu2.1) ...
Setting up libxslt1.1:amd64 (1.1.29-5ubuntu0.1) ...
Setting up libdevmapper-event1.02.1:amd64 (2:1.02.145-4.1ubuntu3.18.04.1) ...
Setting up binutils-common:amd64 (2.30-21ubuntu1~18.04.2) ...
Setting up busybox-initramfs (1:1.27.2-2ubuntu3.2) ...
Setting up libsndfile1:amd64 (1.0.28-4ubuntu0.18.04.1) ...
Setting up libfontembed1:amd64 (1.20.2-0ubuntu3.1) ...
Setting up libx11-xcb1:amd64 (2:1.6.4-3ubuntu0.2) ...
Setting up bubblewrap (0.2.1-1ubuntu0.1) ...
Setting up libglib2.0-data (2.56.4-0ubuntu0.18.04.4) ...
Setting up libdbusmenu-glib4:amd64 (16.04.1+18.04.20171206-0ubuntu2) ...
Setting up krb5-locales (1.16-2ubuntu0.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libmm-glib0:amd64 (1.10.0-1~ubuntu18.04.2) ...
Setting up libperl5.26:amd64 (5.26.1-6ubuntu0.3) ...
Setting up udev (237-3ubuntu10.24) ...
update-initramfs: deferring update (trigger activated)
Setting up language-pack-it (1:18.04+20190718) ...
Setting up libldap-2.4-2:amd64 (2.4.45+dfsg-1ubuntu1.2) ...
Setting up epiphany-browser-data (3.28.5-0ubuntu1+elementary20~ubuntu5.0.1) ...
dpkg: error processing package libplank-common (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Processing triggers for doc-base (0.10.8) ...
Processing 4 changed doc-base files...
Setting up language-pack-gnome-pl (1:18.04+20190718) ...
Setting up gpgsm (2.2.4-1ubuntu1.2) ...
Setting up libdns-export1100 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up openssl (1.1.1-1ubuntu2.1~18.04.4) ...
Installing new version of config file /etc/ssl/openssl.cnf ...
Setting up libplymouth4:amd64 (0.9.3-1ubuntu7.18.04.2) ...
Setting up wget (1.19.4-1ubuntu2.2) ...
Setting up libupower-glib3:amd64 (0.99.7-2ubuntu0.18.04.1) ...
Setting up gnupg-utils (2.2.4-1ubuntu1.2) ...
Setting up vim-common (2:8.0.1453-1ubuntu1.1) ...
Setting up libsqlite3-0:amd64 (3.22.0-1ubuntu0.1) ...
Setting up dmsetup (2:1.02.145-4.1ubuntu3.18.04.1) ...
update-initramfs: deferring update (trigger activated)
Setting up language-pack-gnome-nl (1:18.04+20190117) ...
Setting up libgles2:amd64 (1.0.0-2ubuntu2.3) ...
Setting up man-db (2.8.3-2ubuntu0.1) ...
Updating database of manual pages ...
Setting up libxkbcommon0:amd64 (0.8.0-1ubuntu0.1) ...
Setting up libical3:amd64 (3.0.5-0elementary5.0.1) ...
Setting up avahi-autoipd (0.7-3.1ubuntu1.2) ...
Setting up libjavascriptcoregtk-4.0-18:amd64 (2.24.2-0ubuntu0.18.04.1) ...
Setting up gstreamer1.0-plugins-base-apps (1.14.4-1ubuntu1.1~ubuntu18.04.1) ...
Setting up libgda-5.0-common (5.2.4-9ubuntu0.1) ...
Setting up libntfs-3g88 (1:2017.3.23-2ubuntu0.18.04.2) ...
Setting up busybox-static (1:1.27.2-2ubuntu3.2) ...
Setting up initramfs-tools-bin (0.130ubuntu3.8) ...
Setting up friendly-recovery (0.2.38ubuntu1.1) ...
Sourcing file `/etc/default/grub'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-55-generic
Found initrd image: /boot/initrd.img-4.15.0-55-generic
Found linux image: /boot/vmlinuz-4.15.0-36-generic
Found initrd image: /boot/initrd.img-4.15.0-36-generic
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
Setting up console-setup-linux (1.178ubuntu2.9) ...
Setting up libpython2.7-minimal:amd64 (2.7.15-4ubuntu4~18.04) ...
Setting up libpci3:amd64 (1:3.5.2-1ubuntu1.1) ...
Setting up dirmngr (2.2.4-1ubuntu1.2) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Setting up irqbalance (1.3.0-0.1ubuntu0.18.04.1) ...
Setting up libglib2.0-bin (2.56.4-0ubuntu0.18.04.4) ...
Setting up policykit-desktop-privileges (0.20ubuntu18.04.1) ...
Setting up gnome-desktop3-data (3.28.2-0ubuntu1.5) ...
Setting up elementary-icon-theme (5.0.3+r2120~ubuntu18.04.1) ...
Setting up libxcb1:amd64 (1.13-2~ubuntu18.04) ...
Setting up libwayland-cursor0:amd64 (1.16.0-1ubuntu1.1~18.04.1) ...
Setting up gstreamer1.0-alsa:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1) ...
Setting up liblwres160:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up rfkill (2.31.1-0.4ubuntu3.3) ...
Setting up libx11-data (2:1.6.4-3ubuntu0.2) ...
Setting up libpython2.7-stdlib:amd64 (2.7.15-4ubuntu4~18.04) ...
Setting up libidn11:amd64 (1.33-2.1ubuntu1.2) ...
Processing triggers for rsyslog (8.32.0-1ubuntu4) ...
Setting up xserver-xorg-legacy (2:1.19.6-1ubuntu4.3) ...
setting xserver-xorg-legacy/xwrapper/allowed_users from configuration file
Setting up libpolkit-gobject-1-0:amd64 (0.105-20ubuntu0.18.04.5) ...
Setting up libdbus-1-3:amd64 (1.12.2-1ubuntu1.1) ...
Setting up gpg (2.2.4-1ubuntu1.2) ...
Setting up language-pack-sv (1:18.04+20190718) ...
Processing triggers for fontconfig (2.12.6-0ubuntu2) ...
Setting up python2.7-minimal (2.7.15-4ubuntu4~18.04) ...
Setting up libavahi-common-data:amd64 (0.7-3.1ubuntu1.2) ...
Setting up language-pack-de (1:18.04+20190117) ...
Setting up libwayland-server0:amd64 (1.16.0-1ubuntu1.1~18.04.1) ...
Setting up libxcb-xkb1:amd64 (1.13-2~ubuntu18.04) ...
Setting up iputils-ping (3:20161105-1ubuntu3) ...
Setting up vim-tiny (2:8.0.1453-1ubuntu1.1) ...
Setting up libgda-5.0-4:amd64 (5.2.4-9ubuntu0.1) ...
Setting up libxcb-present0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libpython3.6-stdlib:amd64 (3.6.8-1~18.04.1) ...
Setting up libswitchboard-2.0-0 (2.3.6~r935+pkg64~ubuntu5.0.1) ...
Setting up console-setup (1.178ubuntu2.9) ...
update-initramfs: deferring update (trigger activated)
Setting up gstreamer1.0-plugins-base:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1) ...
Setting up libgeocode-glib0:amd64 (3.25.4.1-4ubuntu0.18.04.1) ...
Setting up libxcb-dri2-0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libxcb-dri3-0:amd64 (1.13-2~ubuntu18.04) ...
Setting up kmod (24-1ubuntu3.2) ...
Installing new version of config file /etc/modprobe.d/blacklist.conf ...
Setting up libk5crypto3:amd64 (1.16-2ubuntu0.1) ...
Setting up libxcb-glx0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libxcb-randr0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libparted2:amd64 (3.2-20ubuntu0.2) ...
dpkg: dependency problems prevent configuration of libplank1:amd64:
 libplank1:amd64 depends on libplank-common (= 0.11.4+git20190318.fb624c21-0elementary5.0.1); however:
  Package libplank-common is not configured yet.

dpkg: error processing package libplank1:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up language-pack-gnome-fr (1:18.04+20190718) ...
Setting up libxcb-xfixes0:amd64 (1.13-2~ubuntu18.04) ...
Setting up language-pack-gnome-de (1:18.04+20190117) ...
Setting up libxcb-render0:amd64 (1.13-2~ubuntu18.04) ...
Setting up python3.6 (3.6.8-1~18.04.1) ...
Setting up libparted-fs-resize0:amd64 (3.2-20ubuntu0.2) ...
Setting up libappstream4:amd64 (0.12.6-0elementary5.0.1) ...
Setting up desktop-file-utils (0.23-1ubuntu3.18.04.2+elementary2~ubuntu5.0.1) ...
Setting up libbinutils:amd64 (2.30-21ubuntu1~18.04.2) ...
Setting up initramfs-tools-core (0.130ubuntu3.8) ...
Setting up libpolkit-agent-1-0:amd64 (0.105-20ubuntu0.18.04.5) ...
Setting up libxcb-res0:amd64 (1.13-2~ubuntu18.04) ...
Setting up language-pack-gnome-sv (1:18.04+20190718) ...
Setting up libdbusmenu-gtk3-4:amd64 (16.04.1+18.04.20171206-0ubuntu2) ...
Setting up libnm0:amd64 (1.10.6-2ubuntu1.1) ...
Setting up libldb1:amd64 (2:1.2.3-1ubuntu0.1) ...
Setting up libx11-6:amd64 (2:1.6.4-3ubuntu0.2) ...
Setting up wpasupplicant (2:2.6-15ubuntu2.3) ...
Setting up python2.7 (2.7.15-4ubuntu4~18.04) ...
Setting up libnss3:amd64 (2:3.35-2ubuntu2.3) ...
Setting up appstream (0.12.6-0elementary5.0.1) ...
Installing new version of config file /etc/apt/apt.conf.d/50appstream ...
AppStream cache update completed successfully.
Setting up initramfs-tools (0.130ubuntu3.8) ...
update-initramfs: deferring update (trigger activated)
Setting up gpg-wks-server (2.2.4-1ubuntu1.2) ...
Setting up parted (3.2-20ubuntu0.2) ...
Setting up gpg-wks-client (2.2.4-1ubuntu1.2) ...
Setting up file (1:5.32-2ubuntu0.2) ...
Setting up libxkbcommon-x11-0:amd64 (0.8.0-1ubuntu0.1) ...
Setting up libpulse0:amd64 (1:11.1-1ubuntu7.2) ...
Setting up libdrm2:amd64 (2.4.97-1ubuntu1~18.04.1) ...
Setting up isc-dhcp-client (4.3.5-3ubuntu7.1) ...
Setting up language-pack-gnome-it (1:18.04+20190718) ...
Setting up libxcb-sync1:amd64 (1.13-2~ubuntu18.04) ...
Setting up perl (5.26.1-6ubuntu0.3) ...
Setting up plymouth (0.9.3-1ubuntu7.18.04.2) ...
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Setting up libpoppler73:amd64 (0.62.0-2ubuntu2.9) ...
Setting up libdrm-intel1:amd64 (2.4.97-1ubuntu1~18.04.1) ...
Setting up libpolkit-backend-1-0:amd64 (0.105-20ubuntu0.18.04.5) ...
Setting up iputils-tracepath (3:20161105-1ubuntu3) ...
Setting up elementary-artwork (1.466+r530~daily~ubuntu5.0.1) ...
Setting up ntfs-3g (1:2017.3.23-2ubuntu0.18.04.2) ...
Processing triggers for systemd (237-3ubuntu10.24) ...
Setting up libpython2.7:amd64 (2.7.15-4ubuntu4~18.04) ...
Setting up libxcb-shm0:amd64 (1.13-2~ubuntu18.04) ...
Setting up pciutils (1:3.5.2-1ubuntu1.1) ...
Setting up libkrb5-3:amd64 (1.16-2ubuntu0.1) ...
dpkg: dependency problems prevent configuration of plank:
 plank depends on libplank1 (= 0.11.4+git20190318.fb624c21-0elementary5.0.1); however:
  Package libplank1:amd64 is not configured yet.

dpkg: error processing package plank (--configure):
 dependency problems - leaving unconfigured
Setting up libavahi-common3:amd64 (0.7-3.1ubuntu1.2) ...
Setting up libdrm-radeon1:amd64 (2.4.97-1ubuntu1~18.04.1) ...
Setting up libavahi-glib1:amd64 (0.7-3.1ubuntu1.2) ...
Setting up apt-config-icons (0.12.6-0elementary5.0.1) ...
Setting up dbus (1.12.2-1ubuntu1.1) ...
A reboot is required to replace the running dbus-daemon.
Please reboot the system when convenient.
Setting up libdrm-nouveau2:amd64 (2.4.97-1ubuntu1~18.04.1) ...
Setting up libpython3.6:amd64 (3.6.8-1~18.04.1) ...
Setting up binutils-x86-64-linux-gnu (2.30-21ubuntu1~18.04.2) ...
Setting up libavahi-core7:amd64 (0.7-3.1ubuntu1.2) ...
Setting up apt-config-icons-large (0.12.6-0elementary5.0.1) ...
Setting up libpython3-stdlib:amd64 (3.6.7-1~18.04) ...
Setting up libcairo2:amd64 (1.15.10-2ubuntu0.1) ...
Setting up libpoppler-glib8:amd64 (0.62.0-2ubuntu2.9) ...
Setting up libpam-systemd:amd64 (237-3ubuntu10.24) ...
Setting up poppler-utils (0.62.0-2ubuntu2.9) ...
Setting up libpulse-mainloop-glib0:amd64 (1:11.1-1ubuntu7.2) ...
Setting up libmagickcore-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.7) ...
Setting up python3 (3.6.7-1~18.04) ...
running python rtupdate hooks for python3.6...
running python post-rtupdate hooks for python3.6...
Setting up libpulsedsp:amd64 (1:11.1-1ubuntu7.2) ...
Setting up gvfs-common (1.36.1-0ubuntu1.3.3) ...
Setting up libdrm-amdgpu1:amd64 (2.4.97-1ubuntu1~18.04.1) ...
Setting up plymouth-label (0.9.3-1ubuntu7.18.04.2) ...
Setting up gstreamer1.0-pulseaudio:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1) ...
Setting up apt-config-icons-hidpi (0.12.6-0elementary5.0.1) ...
Setting up pulseaudio-utils (1:11.1-1ubuntu7.2) ...
Processing triggers for cracklib-runtime (2.9.2-5build1) ...
Setting up policykit-1 (0.105-20ubuntu0.18.04.5) ...
Setting up gvfs-bin (1.36.1-0ubuntu1.3.3) ...
Setting up libcairo-gobject2:amd64 (1.15.10-2ubuntu0.1) ...
Setting up libgbm1:amd64 (19.0.2-1ubuntu1.1~18.04.2) ...
Setting up gnupg (2.2.4-1ubuntu1.2) ...
Setting up libgl1-mesa-dri:amd64 (19.0.2-1ubuntu1.1~18.04.2) ...
Setting up apache2-bin (2.4.29-1ubuntu4.8) ...
Setting up dbus-x11 (1.12.2-1ubuntu1.1) ...
Setting up python3-gi (3.26.1-2ubuntu1) ...
Setting up python3-netifaces (0.10.4-0.1build4) ...
Setting up dbus-user-session (1.12.2-1ubuntu1.1) ...
Setting up libgssapi-krb5-2:amd64 (1.16-2ubuntu0.1) ...
Setting up libcamel-1.2-61:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up apt-config-icons-large-hidpi (0.12.6-0elementary5.0.1) ...
Setting up gvfs-libs:amd64 (1.36.1-0ubuntu1.3.3) ...
Setting up libmagickwand-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.7) ...
Setting up python3-gdbm:amd64 (3.6.8-1~18.04) ...
Setting up libavahi-client3:amd64 (0.7-3.1ubuntu1.2) ...
Setting up libegl-mesa0:amd64 (19.0.2-1ubuntu1.1~18.04.2) ...
Setting up binutils (2.30-21ubuntu1~18.04.2) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Setting up libdns1100:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up openssh-client (1:7.6p1-4ubuntu0.3) ...
Setting up networkd-dispatcher (1.7-0ubuntu3.3) ...
Setting up packagekit (1.1.9-1ubuntu2.18.04.5) ...
Setting up libglx-mesa0:amd64 (19.0.2-1ubuntu1.1~18.04.2) ...
Setting up libcups2:amd64 (2.2.7-1ubuntu2.6) ...
Setting up pulseaudio (1:11.1-1ubuntu7.2) ...
Setting up ufw (0.36-0ubuntu0.18.04.1) ...
Installing new version of config file /etc/default/ufw ...
Replacing config file /etc/ufw/before.rules with new version
Replacing config file /etc/ufw/before6.rules with new version
Setting up gvfs-daemons (1.36.1-0ubuntu1.3.3) ...
Setting up samba-libs:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.11) ...
Setting up python3-apt (1.6.4+elementary6~ubuntu5.0.1) ...
Setting up libedataserver-1.2-23:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up libcurl3-gnutls:amd64 (7.58.0-2ubuntu3.7) ...
Setting up cups-ipp-utils (2.2.7-1ubuntu2.6) ...
Setting up language-selector-common (0.188.3+elementary4~ubuntu5.0.1) ...
Installing new version of config file /etc/fonts/conf.avail/64-language-selector-prefer.conf ...
Installing new version of config file /etc/fonts/conf.avail/69-language-selector-ja.conf ...
Installing new version of config file /etc/fonts/conf.avail/69-language-selector-zh-hk.conf ...
Setting up gstreamer1.0-packagekit (1.1.9-1ubuntu2.18.04.5) ...
Setting up libcurl4:amd64 (7.58.0-2ubuntu3.7) ...
Setting up libcupsmime1:amd64 (2.2.7-1ubuntu2.6) ...
Setting up libebackend-1.2-10:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up cups-daemon (2.2.7-1ubuntu2.6) ...
Setting up python3-gi-cairo (3.26.1-2ubuntu1) ...
Setting up netplan.io (0.97-0ubuntu1~18.04.1) ...
Setting up libgtk-3-0:amd64 (3.22.30-1ubuntu4) ...
Setting up libebook-contacts-1.2-2:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up libsmbclient:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.11) ...
Setting up libcupsppdc1:amd64 (2.2.7-1ubuntu2.6) ...
Setting up libcupsfilters1:amd64 (1.20.2-0ubuntu3.1) ...
Setting up gvfs:amd64 (1.36.1-0ubuntu1.3.3) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up libisccfg160:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up libcupsimage2:amd64 (2.2.7-1ubuntu2.6) ...
Setting up libegl1:amd64 (1.0.0-2ubuntu2.3) ...
Setting up network-manager (1.10.6-2ubuntu1.1) ...
Setting up ubuntu-drivers-common (1:0.5.2.3) ...
Setting up pulseaudio-module-bluetooth (1:11.1-1ubuntu7.2) ...
Setting up nplan (0.97-0ubuntu1~18.04.1) ...
Setting up libnautilus-extension1a:amd64 (1:3.26.4-0~ubuntu18.04.4) ...
Setting up cups-filters-core-drivers (1.20.2-0ubuntu3.1) ...
Setting up libsane1:amd64 (1.0.27-1~experimental3ubuntu2.1) ...
Setting up packagekit-tools (1.1.9-1ubuntu2.18.04.5) ...
Setting up libedata-book-1.2-25:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up ubuntu-minimal (1.417.2) ...
Setting up libgnome-desktop-3-17:amd64 (3.28.2-0ubuntu1.5) ...
Setting up libglx0:amd64 (1.0.0-2ubuntu2.3) ...
Setting up libgs9:amd64 (9.26~dfsg+0-0ubuntu0.18.04.9) ...
Setting up cups-client (2.2.7-1ubuntu2.6) ...
Setting up sane-utils (1.0.27-1~experimental3ubuntu2.1) ...
Setting up libcupscgi1:amd64 (2.2.7-1ubuntu2.6) ...
Setting up libegl1-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.2) ...
Setting up libgranite5:amd64 (5.2.4+r1403+pkg108~ubuntu5.0.1) ...
Setting up gvfs-backends (1.36.1-0ubuntu1.3.3) ...
Setting up elementary-minimal (1.466+r530~daily~ubuntu5.0.1) ...
Setting up libecal-1.2-19:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up gir1.2-gtk-3.0:amd64 (3.22.30-1ubuntu4) ...
Setting up cups-browsed (1.20.2-0ubuntu3.1) ...
Setting up curl (7.58.0-2ubuntu3.7) ...
Setting up libgweather-3-15:amd64 (3.28.2-1~ubuntu18.04.1) ...
Setting up libirs160:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up gvfs-fuse (1.36.1-0ubuntu1.3.3) ...
Setting up libbind9-160:amd64 (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up libevdocument3-4:amd64 (3.28.4-0ubuntu1.2+elementary2~ubuntu5.0.1) ...
Setting up cups-ppdc (2.2.7-1ubuntu2.6) ...
Setting up ghostscript (9.26~dfsg+0-0ubuntu0.18.04.9) ...
Setting up cups-core-drivers (2.2.7-1ubuntu2.6) ...
Setting up network-manager-config-connectivity-ubuntu (1.10.6-2ubuntu1.1) ...
Setting up cups-bsd (2.2.7-1ubuntu2.6) ...
Setting up libedata-cal-1.2-28:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up libevview3-3:amd64 (3.28.4-0ubuntu1.2+elementary2~ubuntu5.0.1) ...
Setting up switchboard (2.3.6~r935+pkg64~ubuntu5.0.1) ...
Setting up libebook-1.2-19:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up libgl1:amd64 (1.0.0-2ubuntu2.3) ...
Setting up ghostscript-x (9.26~dfsg+0-0ubuntu0.18.04.9) ...
Setting up libnoise-core0 (5.0.4+r2721+pkg114~ubuntu5.0.1) ...
Setting up browser-plugin-evince (3.28.4-0ubuntu1.2+elementary2~ubuntu5.0.1) ...
Setting up evolution-data-server (3.28.5-0ubuntu0.18.04.2) ...
Setting up bind9-host (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up evince (3.28.4-0ubuntu1.2+elementary2~ubuntu5.0.1) ...
Installing new version of config file /etc/apparmor.d/abstractions/evince ...
Installing new version of config file /etc/apparmor.d/usr.bin.evince ...
Setting up elementary-desktop (1.466+r530~daily~ubuntu5.0.1) ...
Setting up libmutter-2-0:amd64 (3.28.4-0ubuntu18.04.1+elementary4~ubuntu5.0.1) ...
Setting up cups-filters (1.20.2-0ubuntu3.1) ...
Setting up libwebkit2gtk-4.0-37:amd64 (2.24.2-0ubuntu0.18.04.1) ...
Setting up libwebkit2gtk-4.0-37-gtk2:amd64 (2.24.2-0ubuntu0.18.04.1) ...
Setting up cups (2.2.7-1ubuntu2.6) ...
Updating PPD files for cups ...
Updating PPD files for cups-filters ...
Updating PPD files for foomatic-db-compressed-ppds ...
Updating PPD files for openprinting-ppds ...
Updating PPD files for brlaser ...
Updating PPD files for c2esp ...
Updating PPD files for foo2zjs-common ...
Updating PPD files for gutenprint ...
Updating PPD files for hpcups ...
Updating PPD files for m2300w ...
Updating PPD files for postscript-hp ...
Updating PPD files for ptouch ...
Updating PPD files for pxljr ...
Updating PPD files for sag-gdi ...
Updating PPD files for splix ...
Setting up dnsutils (1:9.11.3+dfsg-1ubuntu1.8) ...
Setting up xserver-xorg-core (2:1.19.6-1ubuntu4.3) ...
Setting up avahi-daemon (0.7-3.1ubuntu1.2) ...
Setting up noise (5.0.4+r2721+pkg114~ubuntu5.0.1) ...
Setting up libedataserverui-1.2-2:amd64 (3.28.5-0ubuntu0.18.04.2) ...
Setting up capnet-assist (2.2.3+r319+pkg26~ubuntu5.0.1) ...
Setting up elementary-standard (1.466+r530~daily~ubuntu5.0.1) ...
Setting up libgeoclue-2-0:amd64 (2.4.7-1ubuntu1+elementary3~ubuntu5.0.1) ...
Setting up liblvm2cmd2.02:amd64 (2.02.176-4.1ubuntu3.18.04.1) ...
Setting up geoclue-2.0 (2.4.7-1ubuntu1+elementary3~ubuntu5.0.1) ...
Installing new version of config file /etc/geoclue/geoclue.conf ...
Setting up dmeventd (2:1.02.145-4.1ubuntu3.18.04.1) ...
dm-event.service is a disabled or a static unit not running, not starting it.
Setting up gnome-settings-daemon (3.28.1-0ubuntu1.3+elementary4~ubuntu5.0.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for initramfs-tools (0.130ubuntu3.8) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-55-generic
Errors were encountered while processing:
 libplank-common
 libplank1:amd64
 plank

It seems they all depend on each other to be installed and I can't seem to figure out how to go about fixing it.

The OS is Elementary OS Juno.

1
  • sudo apt-get install --reinstall #firstpackagename# works perfectly fine. Commented Mar 20, 2020 at 5:02

2 Answers 2

3

This is the source of your problems:

dpkg: error processing package libplank-common (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration

To reinstall the package, run

sudo apt-get install --reinstall libplank-common

That might fail, in which case you can try

sudo dpkg -i /var/cache/apt/archives/libplank-common*0.11.4+git20190318.fb624c21-0elementary5.0.1*.deb
1
sudo dpkg --force-depends -r ppp

is what did the trick for me. Got that from Reddit: Upgrade to 21.10 failed! Please help!!

1
  • This one helped me as the last step in the accepted answer also failed in my case. Commented Jul 23, 2022 at 22:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .