3

I'm trying to upgrade a freshly installed Fedora 30 with sudo dnf update and sudo dnf upgrade but I'm running into issues, here is the partial output:

....
[MIRROR] util-linux-2.33.2-2.fc30.x86_64.rpm: Curl error (28): Timeout was reached for http://mirror.cse.iitk.ac.in/fedora/linux/updates/30/Everything/x86_64/Packages/u/util-linux-2.33.2-2.fc30.x86_64.rpm [Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds]
(474/479): util-linux-2.33.2-2.fc30.x86_64.rpm                       12 kB/s | 2.4 MB     03:15    
(475/479): vid.stab-1.1.0-11.20190213gitaeabc8d.fc30.x86_64.rpm      22 kB/s |  45 kB     00:02    
(476/479): vim-minimal-8.1.1713-1.fc30.x86_64.rpm                   100 kB/s | 563 kB     00:05    
(477/479): selinux-policy-targeted-3.14.3-42.fc30.noarch.rpm         17 kB/s |  14 MB     14:43    
(478/479): virtualbox-guest-additions-6.0.10-1.fc30.x86_64.rpm       84 kB/s | 1.3 MB     00:15    
(479/479): linux-firmware-20190717-99.fc30.noarch.rpm                24 kB/s |  61 MB     44:06    
----------------------------------------------------------------------------------------------------
Total                                                                54 kB/s | 209 MB     66:24     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/man/man5/idmapd.conf.5.gz from install of nfs-utils-1:2.4.1-0.fc30.x86_64 conflicts with file from package libnfsidmap-1:2.3.3-7.rc2.fc30.x86_64

Error Summary
-------------

There was no issues while install the OS.
Here is my system info:

          /:-------------:\          joe@fedora 
       :-------------------::        ---------- 
     :-----------/shhOHbmp---:\      OS: Fedora 30 (Workstation Edition) x86_64 
   /-----------omMMMNNNMMD  ---:     Host: Dell System XPS L502X 
  :-----------sMMMMNMNMP.    ---:    Kernel: 5.0.9-301.fc30.x86_64 
 :-----------:MMMdP-------    ---\   Uptime: 3 mins 
,------------:MMMd--------    ---:   Packages: 1883 (rpm) 
:------------:MMMd-------    .---:   Shell: bash 5.0.7 
:----    oNMMMMMMMMMNho     .----:   Resolution: 1366x768 
:--     .+shhhMMMmhhy++   .------/   DE: GNOME 3.32.1 
:-    -------:MMMd--------------:    Theme: Adwaita [GTK2/3] 
:-   --------/MMMd-------------;     Icons: Tela [GTK2/3] 
:-    ------/hMMMy------------:      Terminal: gnome-terminal 
:-- :dMNdhhdNMMNo------------;       CPU: Intel i5-2410M (4) @ 2.900GHz 
:---:sdNMMMMNds:------------:        GPU: Intel 2nd Generation Core Processor Family 
:------:://:-------------::          GPU: NVIDIA GeForce GT 525M 
:---------------------://            Memory: 2183MiB / 11899MiB 

All help appreciated.

2
  • 1
    Search finds bugzilla.redhat.com/show_bug.cgi?id=1724305 Is the problem fixed if you run dnf update libnfsidmap nfs-utils ?
    – sourcejedi
    Jul 28, 2019 at 14:42
  • "Please can you copy and paste the text" : If it is on system info -- done, else, please specify, ready to help. Running dnf update -y libnfsidmap nfs-utils reproduces the error. Jul 29, 2019 at 4:03

2 Answers 2

1

I've tried the workaround and it didn't help (dnf update -y libnfsidmap nfs-utils)

I did another workaround that let me upgrade everything except nfs-utils, these are the steps:

  1. Edit the file /etc/dnf/dnf.conf and add the line: exclude=nfs-utils. Your file should look something like:
[main]
gpgcheck=1
installonly_limit=3
clean_requirements_on_remove=True
exclude=nfs-utils
  1. Upgrade as normaly: sudo dnf update -y
0

It sometimes happens that there are conflicts in the repositories. Try e.g. dnf upgrade --exclude <offending-packages>. Check dnf's manpage, you can ask to try best options, delete packages that stand in the way, and so on. Most of the time the problem clears in a day or some hours. I've had such problems after upgrading when stale packages are left behind, that aren't supported anymore but block others. Just get rid of cruft. It might also happen if the database gets scrambled, for example a dnf run crashes and doesn't clean out the old versions. Run dnf list installed (from memory, machine not at hand right now), sort that and look for duplicates. Erase the old duplicates (will need the full rpm name), possibly using the rpm command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.