2

I have Dell Latitude E6540 which has Radeon HD8790M and it runs Debian 10. I wanted to install newest drivers for said video card (becuase games didn't recognize it and I couldn't see it's usage (radeontop says "radeon unknown" and shows 0% usage on everything)).
So I downloaded AMD Radeon Software Crimson Edition 15.12 Proprietary Linux x86 Display Driver but when installing it says:

error: Detected X Server version 'XServer 1.20.4_64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib32:XServer 1.20.4_64a:none:4.19.0-5-amd64:)

Should I:

  • install xserver 1.10
  • install other driver
  • do something else
  • ? I can provide more information if required.

    • Just a note, it is highly not recommended to installed the proprietary drivers as a blob, outside of the package manager, in order to avoid breaking the system each time and create a Frankendebian – Paradox Jul 30 '19 at 15:07
    0

    Ok, nevermind, my bad. The drivers I already had (amdgpu or something) were indeed working, it's just that I didn't tell (e.g.) steam to use my dedicated gpu (by launching it with DRI_PRIME=1 steam). And radeontop is also working.

    • Could you add some details so this question can be helpful to others? – Paradox Jul 30 '19 at 17:45

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.