1

I'm noticed in NetBeans in Windows 10 - if I set editor font to "Courier New" - line spacing is normal. Then if font is set to "DialogInput" - line spacing is about 1:2, easier to read/work. "DialogInput" font is simply "Courier New", but in this case somehow modified? On CentOS I see no difference. Is it possible to match "DialogInput" font with "Courier New" plus some line spacing properties? I can set line spacing in NetBeans properties at ~/.netbeans/11.1/config/Editors/Preferences/org-netbeans-modules-editor-settings-CustomPreferences.xml with:

<entry javaType="java.lang.Float" name="line-height-correction" xml:space="preserve">  

But trying to find if it is possible to do that with /etc/fonts/fonts.conf file.

EDIT:

Dialog and DialogInput fonts are controlled by Java. I found that in JDK12 file (both on CentOS and Win10) /usr/java/latest/lib/psfontj2d.properties contains:

#
# Legacy logical font family names and logical font aliases should all
# map to the primary logical font names.
#
serif=serif
times=serif
timesroman=serif
sansserif=sansserif
helvetica=sansserif
dialog=sansserif
dialoginput=monospaced
monospaced=monospaced
courier=monospaced

So those fonts are simply sansserif and monospaced. And NetBeans settings file ~/.netbeans/11.1/config/Editors/Preferences/org-netbeans-modules-editor-settings-CustomPreferences.xml is exatcly the same on CentOS and Win10. So still can not uderstand this different behaviour..

  • Not possible AFAIK. – contemplator Jul 27 '19 at 12:21
  • Some info about font properties here: FONT PROPERTIES. If NetBeans on Win10 accepts one of them, on CentOS it should do the same (binaries identical). Just need to find out which one - perhaps line-height-correction, I will try tp lace it in fonts.conf. – Ernestas Gruodis Jul 27 '19 at 13:18
  • It's likely that Windows applies some tweaks to set a fixed line spacing for the DialogInput font. If you're not content with your workaround for Netbeans I'll suggest to you to modify the font's line spacing in FontForge. – contemplator Jul 27 '19 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.