4

I'm trying to upgrade an old server from Debian wheezy (yes, I'm behind the times). Can you tell me how to overcome a conflict between systemd-sysv and sysvinit?


I replaced mentions of wheezy with jessie in apt lists: sed -i 's/wheezy/jessie/g' sources.list sources.list.d/*

When I run apt -V upgrade, I encounter an error:

dpkg: error processing archive /var/cache/apt/archives/systemd-sysv_241-5_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man8/halt.8.gz', which is also in package sysvinit 2.88dsf-41+deb7u1

I tried to remove the existing sysvinit package with dpkg -P sysvinit, but it is not allowed because this is an essential package:

dpkg: error processing package sysvinit (--purge):
 this is an essential package; it should not be removed

(I have also tried apt --fix-broken install, but to no effect.)

1
  • systemd-sysv 241-5 is the buster version, not the jessie one. Upgrading from wheey to buster in one step is not supported, you have to go step by step: wheezy -> jessie -> stretch -> buster. Commented Aug 3, 2019 at 21:09

2 Answers 2

7

I also experienced a similar problem. Solved by

dpkg -P --force-remove-essential sysvinit
1
  • very helpful.I solved using this comand. Commented Sep 24, 2020 at 17:19
1

It happened to me when I upgraded from Debian 9 Stretch into 10 Buster, where libpam-systemd requires systemd-sysv.

This worked for me:

  1. Add apt sources for Buster:

     deb http://ftp.de.debian.org/debian/ buster main
     deb-src http://ftp.de.debian.org/debian/ buster main
     deb http://security.debian.org/debian-security buster/updates main
     deb-src http://security.debian.org/debian-security buster/updates main
    

and then

  1. apt-get build-dep systemd-sysv

One of the things which happened is that libpam-systemd was removed by apt and therefore this dependency request vanished.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .