0

I upgraded my system recently, and now I am seeing a really bizarre error, any ideas on what I can do to fix this issue?:

nslookup 8.8.8.8
../../../../lib/isc/unix/socket.c:2135: internal_send: 192.168.43.232#53: Required key not available
../../../../lib/isc/unix/socket.c:2137: unable to convert errno to isc_result: 126: Required key not available
8.8.8.8.in-addr.arpa    name = dns.google.

Authoritative answers can be found from:

Edits:

Unfortunately I did not take note of which versions as it was done through the software center app, I'm running a variant of Ubuntu 18.04 ( pop_os )

systemd-resolve --status:

Global
     DNS Servers: 192.168.43.220


Link 3 (wlp113s0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
         DNS Servers: 192.168.43.232
                      2600:1014:b02f:45d5::c3

nmap -p 53 -Pn 192.168.43.232

Starting Nmap 7.60 ( https://nmap.org ) at 2019-07-26 14:00 CDT
Nmap scan report for 192.168.43.232
Host is up.

PORT   STATE    SERVICE
53/tcp filtered domain

Nmap done: 1 IP address (1 host up) scanned in 2.03 seconds

dig 8.8.8.8:

../../../../lib/isc/unix/socket.c:2135: internal_send: 192.168.43.232#53: Required key not available
../../../../lib/isc/unix/socket.c:2137: unable to convert errno to isc_result: 126: Required key not available

; <<>> DiG 9.11.3-1ubuntu1.8-Ubuntu <<>> 8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49678
;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;8.8.8.8.           IN  A

;; ANSWER SECTION:
8.8.8.8.        0   IN  A   8.8.8.8

;; Query time: 6 msec
;; SERVER: 2600:1014:b02f:45d5::c3#53(2600:1014:b02f:45d5::c3)
;; WHEN: Fri Jul 26 14:03:02 CDT 2019
;; MSG SIZE  rcvd: 41

Possibly related:

possible solutions

  • Try unblocking port 53.
  • I had an issue where docker-compose was doing something weird to the network, so I ran docker-compose down && docker-compose up
4
  • Update question with details of what you upgraded from, and what you upgraded to ?
    – steve
    Jul 26, 2019 at 17:50
  • What's 192.168.43.232? If it's a different machine to the one on which you're running nslookup, does it work correctly? Are you using DNSSec? What is in your client's /etc/resolv.conf? Does dig 8.8.8.8 work any better? Jul 26, 2019 at 18:12
  • A problem is that you're filtering tcp/53. Unblock that and try again. Jul 26, 2019 at 19:11
  • @roaima Thank you so much. For some reason or another the iptables were messed up somehow. I ran iptables -F and can now nslookup.
    – jmunsch
    Jul 26, 2019 at 19:22

1 Answer 1

0

One problem is that you're filtering TCP port 53. (DNS uses UDP for short quick queries, and TCP for longer messages.) Unblock that and try again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .