1

When I switch from powerlevel9k to powerlevel10k, some extra space appears at the end of each line.

enter image description here

How can I remove this space?

1

According to this GitHub issue:

This difference is due to a bug Powerlevel9k that is too severe to emulate in Powerlevel10k.

If you want your right prompt to be at the edge of the screen without indentation, add ZLE_RPROMPT_INDENT=0 to your ~/.zshrc and restart zsh. The default value of this parameter is 1, hence the space you are seeing. This parameter is respected by all prompts except Powerlevel9k.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.