2

I have a new Gentoo server installed on virtual, with virtual lan interface. When booting from live CD, network (eth0) is available. When booting into the newly-created system, the network is missing at startup. The interface is shown in dmesg. In ifconfig, eth0 is missing.

What's wrong?

enter image description here enter image description here

5
  • use ip link show and put your output here. Commented Jul 24, 2019 at 14:15
  • I can't get text only output... i must inserted here as a picture... for this time... Later I investigate how get text output from ms virtual machine.
    – exo
    Commented Jul 24, 2019 at 14:21
  • ip likn show is in the picture up.
    – exo
    Commented Jul 24, 2019 at 14:23
  • Hi and welcome! Thanks for contributing! But please, don't post images of text (read this for reasons why).
    – Kusalananda
    Commented Jul 24, 2019 at 19:29
  • I understand difference bwtween picture and text output.. But it's no way how to get text from ms virtual without network and ssl acces to putty or some other external consolas.
    – exo
    Commented Aug 5, 2019 at 7:09

3 Answers 3

2

The problem was in the poorly translated kernel. Bad config file caused that the changes associated with enabling virtualization options did not take effect.

After repairing and rebuilding the new kernel, eth0 is available and the net working perfect.

1

your interface is bond0 just use this command dhclient to get the IP from your VM's DHCP server

dhclient 
13
  • uf... In installation process there was thre interfaces, lo, bound0, eth0. After reboot eth0 missined... I thinked, that bound0 is for network bounding... Ok. I test configure bond0 as eth0 and see if it will be ok. Thx.
    – exo
    Commented Jul 24, 2019 at 14:35
  • you're welcome if you have any problem to your interface name you can change this vim /etc/sysconfig/network-scripts/ifcfg-bound0 and change the DEVICE name to eth0 and reset the networks service Commented Jul 24, 2019 at 14:42
  • Did you (both) mean bond0 instead of bound0?
    – Jeff Schaller
    Commented Jul 24, 2019 at 14:46
  • Yes. bond0. (bound0 was my mistake)
    – exo
    Commented Jul 24, 2019 at 14:47
  • I have no path /etc/sysconfig...
    – exo
    Commented Jul 24, 2019 at 14:48
0

Your ethernet is bond0, You can do it:
ip address add NEW_IP dev bond0
Of course you need to specify gateway such as :
ip route add default via YOUR_DEFAULT_GATEWAY dev bond0

Or if you have DHCP server you need to run dhclient bond0

1
  • Even if bonding is enabled, why would the raw interface disappear? (I mean, that's not how it worked when I've used it.) Or, alternatively, why would something rename the interface?
    – ilkkachu
    Commented Jul 24, 2019 at 19:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .