1

Trying to install the last version of OpenNMS in the last stable version of Debian, following the official installation instructions leads to an apt error with the repositories:

root@triplecero:~# apt update
Ign:1 http://nightly.odoo.com/12.0/nightly/deb ./ InRelease
Ign:2 https://debian.opennms.org stable InRelease
Hit:3 http://nightly.odoo.com/12.0/nightly/deb ./ Release
Hit:4 https://debian.opennms.org stable Release
Hit:7 http://ftp.debian.org/debian buster-backports InRelease
Hit:8 http://deb.debian.org/debian buster InRelease
Hit:9 http://repo.mysql.com/apt/debian stretch InRelease
Hit:10 http://deb.debian.org/debian-security buster/updates InRelease
Hit:11 http://deb.debian.org/debian buster-updates InRelease
Hit:12 http://linorg.usp.br/debian-marillat stable InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
W: Conflicting distribution: https://debian.opennms.org stable Release (expected stable but got opennms-24)
root@triplecero:~#

That error can be fixed just changing the stable keyword in /etc/apt/sources.list.d/opennms.list repository file with opennms-24.

root@triplecero:~# apt update
Hit:1 http://repo.mysql.com/apt/debian stretch InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 http://deb.debian.org/debian-security buster/updates InRelease
Hit:4 http://ftp.debian.org/debian buster-backports InRelease
Ign:5 http://nightly.odoo.com/12.0/nightly/deb ./ InRelease
Hit:6 http://deb.debian.org/debian buster-updates InRelease
Hit:7 http://nightly.odoo.com/12.0/nightly/deb ./ Release
Hit:9 http://linorg.usp.br/debian-marillat stable InRelease
Ign:10 https://debian.opennms.org opennms-24 InRelease
Get:11 https://debian.opennms.org opennms-24 Release [11.2 kB]
Get:12 https://debian.opennms.org opennms-24 Release.gpg [224 B]
Get:13 https://debian.opennms.org opennms-24/main Sources [3,696 B]
Get:14 https://debian.opennms.org opennms-24/main i386 Packages [25.8 kB]
Get:15 https://debian.opennms.org opennms-24/main i386 Contents (deb) [97.6 kB]
Fetched 138 kB in 18s (7,643 B/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
root@triplecero:~#

But after that, I get dependency errors from apt when I'm trying to install OpenNMS (trying to install those packages leads to another dependency package errors).

root@triplecero:~# apt install opennms
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 opennms : Depends: opennms-server (= 24.1.2-1) but it is not going to be installed
           Depends: opennms-webapp-jetty (= 24.1.2-1) but it is not going to be installed
           Recommends: opennms-source (= 24.1.2-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@triplecero:~#

Changing the repository from opennms-24 to opennms-23 or opennms-22 leads to another unmet dependency errors with PostgreSQL.

Seems obvious the Debian OpenNMS repository has broken dependency packages. There's any other alternative to this or just have to wait to be fixed...?

  • Yes I did, after post this question I created an account in OpenNMS Community and post this very message. The issue was solved: link. – abiyi Jul 25 at 21:33
0

As I thought the apt error message was caused by an error in the OpenNMS repository: two deb packages with libraries needed, jicmp and jicmp6, weren't available in the repository for i386 architectures.

After reporting the issue the packages are now available and the opennms package can be installed fulfilling the dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.