1

I have a brand new Purism laptop (Librem 15 version 3) with PureOS I started up for the first time today.

While setting it up to my liking, I opened Gnome Tweaks to change the Caps Lock button to be a Control key. Immediately upon changing the setting (without any other action on my part), the system locked the screen and any further efforts to log in result in the screen going blank momentarily and the lock screen being displayed.

Unsurprisingly, this makes the laptop unusable. There's no bug report regarding this.

I was unable to usefully identify the laptop based on the information at wiki.puri.sm/hw. I consulted my order information instead.

It doesn't appear to boot grub, but I'm not sure I'd know. I can reach the BIOS settings, but nothing there seems to do anything useful. As to rebooting, I did try that immediately. No change. I can log in using Ctrl+Alt+F3, as suggest, but there's no server running a display at that point. I'll be awaiting a response from Purism before I wipe my user configuration.

2
  • 2
    A complete power cycle seems the first thing to try. I see that Purism laptops use coreboot, rather than a more traditional BIOS. Do you know if it boots grub? If it does then you can probably stop it at the grub stage and boot into single user mode. At that point you could wipe out your user configuration and see if this fixes the issue. Another option is to switch to a different virtual terminal, using ctrl+alt+f3, and log in there.
    – icarus
    Jul 23, 2019 at 23:01
  • 3
    Not sure what BIOS settings there are to be changed - typically coreboot loads a payload (very quickly). It is expected that there is no server running a display when logging in via ctrl-alt-f3 - this is a good thing as your display server seems to be crashing. If you don't want to wipe out everything, you could run mv .config my_old.config;sync and then power cycle quickly to stop anything from recreating the (possibly) faulty config. You can access all your changes/configuration in the my_old.config directory and copy them back. If you want help from Purism rather than us, I will stop.
    – icarus
    Jul 23, 2019 at 23:52

1 Answer 1

1

With help from Purism support and commenter @icarus above, I was able to remove the offending configuration at ~/.config/dconf/user and rebooting.

Moreover, I was able to achieve my intended result by modifying /etc/defaults/keyboard as seen here.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .