1

Versions of LibreOffice starting from 6.2.4 are not able to run on CentOS 7.6. Running libreoffice6.2 exits with code 139.

There are old bug reports (e.g. this) which have similar symptoms but are related to a different problem. This particular error is not related to Java 9+ (as remove Java from the system does not solve the problem).

Downgrading to 6.2.3 resolves the issue.

1
  • Please note, I've posted this question along with the answer to record solution to the problem which bugged me for weeks along with the way how to find it. Hopefully it will help someone save time.
    – scrutari
    Jul 23, 2019 at 22:10

1 Answer 1

0

After a crash LibreOffice creates dump file path to which can be found in ~/.config/libreoffice/4/crash/dump.ini. Checking dumps reveals that there are some dependent libraries that cannot be loaded, e.g.:

cannot open shared object file.libKF5KIOFileWidgets.so.5

These libraries, found one by one, suggest that the following packages must be installed to allow new versions of LibreOffice to run:

yum install kf5-kcoreaddons kf5-ki18n kf5-kconfig-core \
    kf5-kwindowsystem kf5-kio-core-libs kf5-kio-file-widgets

All of these packages are in EPEL repository. Once they are installed, LibreOffice 6.2.4+ runs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .