1

So I've got a Debian 9 machine with 5 hard drives in it. I tried moving these drives to a new machine and hoping they would boot. When I did this, I got "normal.mod not found" and it kicked me to grub rescue.

After messing around with every version of grub repair, I didn't make any progress. So I moved the drives back into the original machine thinking that it'd be easier to just get that working again?

Well now it's getting "filesystem unknown" and moving me into grub rescue. I again tried various grub rescues, and boot-repair and most of these fail because they aren't booted in UEFI mode, but they won't boot in UEFI mode, usually because they also say "filesystem unknown".

So just now I booted into a live Ubuntu and installed boot-repair and just used it to set up an MBR thinking that'd be better than a non working gpt efi grub but now it's saying no operating system found. This is the output log from doing that: https://pastebin.com/46gjUB3p

For some context, and yeah I know past me really was on something deciding all of the various drives to boot from, but /dev/sdc1 is /root /dev/sdd1 is my EFI grub partition, and now /dev/sdb is where the mbr is.

I've also tried every boot order in the BIOS as well as physically unplugging all drives except for sdc and sdd and had the same issues.

I'm relatively competent in using linux, so I'll try anything, I'm just obviously not very good at figuring out what's wrong.

  • I didn't understand if you tried changing the boot order in your bios. Did you? – guillermo chamorro Jul 23 at 13:06
  • Oh yeah, I should have mentioned that and I'll edit to include, but I changed the boot order and tried physically removing all drives but sdc and sdd and continued having the same issues. – Josh Jul 23 at 13:18
  • My guess is that it is not related to sd*, gpt*, but hd*. In your grub.cfg it'set set root='hd0,gpt1', but now the (boot) disk is hd1 for example. – guillermo chamorro Jul 23 at 13:45
  • In the grub rescue> terminal you can type the command ls to check which disk is which. – guillermo chamorro Jul 23 at 13:52
  • Oh good call. Sorry, I've done so much stuff over the last few days I've forgotten it all. So I was able to do that and use set to change the boot and root partitions to the right drive, and it would start booting, but then it would stop saying "changing nouveafb from VGA" or something along those lines. But of course with my screwing around I don't even get grub rescue any more. – Josh Jul 23 at 14:35
0

If you don't manage to boot via grub rescue, you could install Super Grub2 Disk to a USB thumb drive to boot into Debian and reinstall grub.

Instructions:

  1. If not already done, I would suggest you put all drives back in to prevent any drive numbering hiccup. Make sure your BIOS is set to UEFI and not to Legacy boot mode. If it's set to UEFI/Legacy mode, make sure it's set to UEFI first.

  2. Prepare a thumb drive with Super Grub2 Disk. You can write it like most ISOs to the thumb drive, either per direct cp to the device, dd, or with Win32DiskImager from Windows.

  3. Boot from the thumb drive, select "Detect and show boot methods" and boot a listed Debian kernel or grubx64.efi.

  4. Reinstall grub as root:

    • Double check you bootet in UEFI mode, directory /sys/firmware/efi should exist.
    • Make sure your EFI system partition /dev/sdd1 is mounted on /boot/efi.
    • Reinstall the grub-efi package (probably not necessary, but won't hurt):

      apt-get install --reinstall grub-efi
      
    • Reinstall grub to the disk containing your EFI system partition. The device name is optional:

      grub-install /dev/sdd
      
    • Update grub:

      update-grub
      
    • Remove thumb drive and reboot.

  5. Check your BIOS settings. The updated/newly created entry should be the first boot entry.

  6. Reboot again.

  • So this definitely seems to be doing something, but it's still not quite there. imgur.com/a/XiIL5hA It's stopping at [end trace ] at boot when selecting my kernel from super grub2 disk – Josh Jul 23 at 17:56
  • I'm thinking I'm just going to backup some data and reinstall linux. I'm just hoping it doesn't cause more/different boot issues at this point D: – Josh Jul 24 at 15:02
  • The kernel panic looks like a hardware/bios or kernel issue, but I don't know what could cause this. Maybe you forgot turn on something in the BIOS settings? If not, backup your data and reinstall. This time create the EFI system partition on the same hdd for less trouble ;) Good luck! – Freddy Jul 24 at 15:18
  • Thanks, that sounds like a plan. Any suggestions on what I should do to the previous EFI/mbr stuff during install to avoid continued issues? – Josh Jul 24 at 15:43
  • If you need any of the EFI stuff on /dev/sdd1 for Windows or another Linux distro, then copy the partition to /dev/sdc1 to be on the safe side before you reinstall. If not, then don't. Then change the partition type of /dev/sdd1 to avoid any confusion (and reformat or delete it later). – Freddy Jul 24 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.