I'm trying to install Arch on a Dell XPS 15 9560.

I've used nomodeset to make the text legible (otherwise it's tiny on the integrated 4k monitor) and pcie_aspm=off to stop the slew of pci bus errors as per a suggestion on the device's Arch Wiki page.

However, when I try to mount the drive I get a slew of errors (continuing forever):

print_req_error: operation not supported error, dev nvme0n1, sector {secnum} flags 9

Where the secnum is gradually increasing, presumably it's going through and trying to do the mount starting at every block but I digress.

Any ideas on how to fix this? I've tried secure erasing the SSD to account for any bugs there but nothing.

The dmesg log can be found here. Please note, I did not include the above kernel flags whilst obtaining this log.

The exact kernel version found using uname -r is: 5.1.15-arch1-1-ARCH. This is the one included in ISO archlinux-2019.07.01-x86_64.iso.

The nvme command suggested in the comments does not seem to exist on the ISO so I have been unable to ascertain the exact SSD model present in the system at this time. Although the device code listed in the dmesg indicates it's probably this one.

The output of journalctl -k -o short-monotonic is here.

  • It's possible this is a defect in the kernel. Please can you edit the question to include the exact kernel version or versions you have seen this behaviour on? Thanks for mentioning all the kernel boot options you have added.
    – sourcejedi
    Jul 26, 2019 at 19:47
  • 1
    Also the specific model of drive used here. I hope nvme id-ctrl will show it, although I'm not familiar with nvme.
    – sourcejedi
    Jul 26, 2019 at 19:53
  • I suspect both of these would have shown up in the kernel log (dmesg command) after booting. We accept big textdumps in questions by linking to gist.github.com (it might be best if you create an account there first though, although I am not certain).
    – sourcejedi
    Jul 26, 2019 at 19:57
  • @sourcejedi thanks for taking the time to respond, sorry it took me a while to get back to you. It's been a busy few days. I've edited the question to show as much detail that you requested as I can. Although the nvme command doesn't seem to exist on the arch boot iso. Jul 30, 2019 at 10:10
  • Again, I personally am not familiar with nvme, I just think it could make a better question if you include this sort of information. Maybe the errors in the dmesg help point towards the root cause. But unfortunately they have flooded the kernel ring-buffer. If you use journalctl -k -o short-monotonic, hopefully you can get the earliest kernel messages as well.
    – sourcejedi
    Jul 30, 2019 at 11:26

1 Answer 1


I encountered this issue today on my Lenovo Yoga 730 with an ADATA NVMe 512G drive. I had errors when running mkfs.ext4, but it did complete. Once I tried to mount the partition I received the same error as described.

I tried the May 2019 Arch release and did not have the problem. Seems the issue was introduced with the June 2019 release. Using the May 2019 ISO, I was able to successfully install Arch on my NVMe drive. The kernel version after install is 5.2.4-arch1-1-ARCH.

  • If you do a full system update do the errors reappear and have you reported this as a bug? Jul 31, 2019 at 10:34
  • I've not seen any issues so far both my main system (Arch) and laptop are at the same level. I've done a full system update and it's fine. I did not report the issue yesterday as I was setting the system up. I did report it this morning.
    – Primo
    Jul 31, 2019 at 15:28
  • And the bounty is yours. That worked! Having issues with xorg now but I think it's unrelated. Thanks for your help! Aug 2, 2019 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.