1

When I run git pull I get the following error:

git-remote-https: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by git-remote-https)

Why is git trying to use libcurl3-openssl-dev while libcurl4-openssl-dev is already installed? The solution is that I install the following packages:

apt install libcurl3 libcurl-openssl1.0-dev

But the above command removes the following packages:

cmake libcurl4 libcurl4-openssl-dev

I don't want cmake to be removed! How can I fix this problem without having cmake removed?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.