2

sorry to jump directly to the issue, but I am facing quite a frustrating issue on Fedora 30. I have been using fedora on both GNOME and Deepin desktop environment till yesterday. Till yesterday I was having an option for Wifi on both Deepin and GNOME, but because I got bored with Deepin, I removed it yesterday using sudo dnf remove "Deepin Desktop".

Now, today when I booted up my laptop, I saw no option for WiFi which usually appears on the top right drop down menu.

enter image description here

I have faced a similar issue when I used to run Ubuntu 18.04, so I knew that I could run wifi using terminal. When I ran ifconfig -a, I got this;

    enp0s20u3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.172  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::4de3:e5f5:3a6f:f2f6  prefixlen 64  scopeid 0x20<link>
        ether 56:a9:71:4b:c4:ac  txqueuelen 1000  (Ethernet)
        RX packets 500  bytes 168101 (164.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 884  bytes 969702 (946.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 50:7b:9d:48:f7:e1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2827  bytes 260162 (254.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2827  bytes 260162 (254.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:3d:1d:2e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0-nic: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 52:54:00:3d:1d:2e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

But no wireless card is detected in this. So I went to WiFi settings, where I found the message shown below.

enter image description here

I have totally wasted my 6 hours trying to fix it myself. I tried sudo dnf install broadcom-wl and then sudo dnf update and finally rebooted, but nothing worked.

It all happened after removing Deeping Desktop Environment yesterday. Even after removing it yesterday, the WiFi worked for as long as I didn't shut down the laptop. Today, as I booted it up, nothing, the WiFi was gone.

Please help me with this issue.

EDITS:

Some points worth mentioning.

  1. I am on dual boot (Windows 10 and Fedora 30) and WiFi is perfectly working on Windows.

  2. As of yesterday, after removing Deepin, I had 3 other DE -> a.) GNOME b.) GNOME Xorg c.) GNOME classic. Today, GNOME Classic is also missing.

Its like my system has got messed up!

  • ask.fedoraproject.org/tags/broadcom may also have an answer for you. – K7AAY Jul 22 '19 at 18:56
  • I removed Fedora and installed Ubuntu 18.04 LTS, WiFi is now working. Although it doesn't solve the issue with Fedora, but my problem is solved. – Himanshu Sharma Jul 24 '19 at 13:36
0

i resolved this problems by download new driver *.ucode (my wifi card is intel). put it to /lib/firmware and restart.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.