2

I try to install Ubuntu 18.04 on a Lenovo Ideapad 320, but the installer always hangs at installing the grub2 package. So I ran the installer with ubiquity -b (no bootloader) and it installs fine. I thought this way I could install grub manually.

When I boot, grub drops to the grub> command line prompt. I can boot using the following commands:

set root=hd0,msdos5
linux /vmlinuz root=/dev/sda5
initrd /initrd.img
boot

I tried getting a normal grub menu in many ways, but none seem to work. I ran grub-install /dev/sda, grub-update, I tried modifying the /etc/default/grub configuration file, etc. But I keep getting the grub> prompt. How do I get the menu?

Edit: This is what /etc/default/grub looks like:

GRUB_DEFAULT=0
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
  • If Secure Boot and Fast Boot are enabled in the BIOS/Firmware setup, please disable them for the installation process. – K7AAY Jul 22 at 16:05
  • What modifying have you done with the configure file? @K7AAY What's the matter with Secure Boot? Grub already worked, it wasn't refused by UEFI firmware, it's just the menu timeout was set to 0, so no menu can be shown – 炸鱼薯条德里克 Jul 22 at 16:10
  • Nah, I did set the timeout, see edit. – nc404 Jul 22 at 17:26
  • I'll check out fast boot and secure boot. – nc404 Jul 22 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.