1

After I upgrade my laptop to Buster (stable) from Stretch (old Stable) I get the following error while I try to connect to my remote workstation:

ssh workstation
sign_and_send_pubkey: signing failed: agent refused operation
workstation@XXX.XXX.XXX.XXX's password: 

If I type the password I'm able to remotely login. The remote machine run Debian Stretch.

I'm no longer able to connect remote machine from nautilus getting this error:

Oops! Something went wrong. 
Don't have permission to access the requested location

Maybe the two problems are related.

  • Have you tried launch a new SSH agent? Alternatively, rebooting the computer? – 41754 Jul 22 at 7:57
  • I have upgraded and rebooted both the laptop and the workstation but the problem persist – Riccardo Jul 22 at 9:20
  • Create a new SSH agent and assoc it by eval $(ssh-agent), then repeat the CLI ssh, read the failure, add the key by ssh-add /PATH/TO/THE/KEY, try ssh again, read the failure again. This might hint you the problem. You might then repeat all of those using increased verbosity. – 41754 Jul 22 at 9:26
  • I tried to resend the key to the client with no luck. I get the same error – Riccardo Jul 22 at 9:48
  • Is your SSH authentication key very old? Try creating a new key; perhaps the old one is too short to be secure by modern standards, or has some other known flaw. – telcoM Jul 22 at 9:52
0

Found the solution here

In particular, the way to solve it is to make sure that I have the correct permission on the id_rsa and id_rsa.pub.

Check the current chmod number by using stat --format '%a' <file>. It should be 600 for id_rsa and 644 for id_rsa.pub.

To change the permission on the files use

chmod 600 id_rsa
chmod 644 id_rsa.pub

That solved my issue with the update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.