1

I understand that with the new Gnome 3 desktop, the System Tray is not enabled by default, and it has to be manually applied by installing gnome-shell-extension-appindicator, however I cannot install this package.

When I run sudo apt install gnome-shell-extension-appindicator, I get this error message in return:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell-extension-appindicator : Depends: gnome-shell (>= 3.31) but 3.30.2-9 is to be installed
E: Unable to correct problems, you have held broken packages.

So my question is, how can I install gnome-shell version 3.31, or if that is impossible, how else could I fix this?

1 Answer 1

1

The version of gnome-shell-extension-appindicator currently in unstable depends on a version of GNOME Shell which is currently only available in experimental. The discrepancy is tracked in #931874, and I imagine it will be fixed when the GNOME 3.32 transition starts.

In the meantime, you can install gnome-shell from experimental yourself:

echo deb http://deb.debian.org/debian experimental main | sudo tee /etc/apt/sources.list.d/experimental.list
sudo apt update
sudo apt -t experimental gnome-shell

(Keep an eye on the last step, it may involve upgrading more than you want. Adding experimental to your repositories is safe because it’s never an installation or even upgrade candidate, unless you change its pin priorities yourself.)

Another solution could be to install gnome-shell-extension-appindicator from Debian 10 instead.

1
  • Thanks, it works now I installed it from the bullseye repo.
    – Daniel M.
    Jul 22, 2019 at 15:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .