0

I have a Logitech M235 2nd generation wireless mouse and I'm on Debian 10 XFCE. My mouse work, is detected and all but I have one thing that doesn't work, the wheel click or middle click. The wheel works, I can scroll web pages but the click doesn't.

It's the first time I install Debian. Previously I had Fedora XFCE and the wheel click worked.

I certainly miss some packages or drivers, I don't know. Can you help me ?

Thank you.

  • There is a bug in Debian 10 where Thunar uses a version not compatible properly with xfdesktop. Therefore, if you right click on the desktop the Thunar Custom Actions, for example, Open Terminal Here, does not appear. Furthermore, the middle click option to go to currently open windows does not work. I tried to remedy this by downgrading Thunar, but it caused too many dependency issues given the glib2 library. bbs.archlinux.org/viewtopic.php?id=240403 This issue is not present in Debian 9.9 or in Xubuntu 18.04. – jbrock Jul 27 at 15:34
  • You can however assign a custom command to the middle click by installing xbindkeys and xautomation. Create your ~/.xbindkeysrc file and add a line like this to run a keyboard shortcut made in Keyboard > Application Shortcuts: "xte 'keydown Control_L' 'keydown Alt_L' 'key B' 'keyup Control_L' 'keyup Alt_L'" b:2 Mine opens up a web browser window. (b:2 should be on a new line.) – jbrock Jul 27 at 15:36
  • Be sure to add xbindkeys to Session and Startup > Application Autostart. – jbrock Jul 27 at 15:59
  • The problem is the middle click isn't even recognized by the system. The xev | grep button command show an output for every button of my mouse (left, right click, wheel scrolled up, wheel scrolled down) but none for a middle click. – Nicryc Jul 27 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.