0

I am using linux mint

ifconfig

does not show enp1s0. it just shows

enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.2.15  netmask 255.255.255.0  broadcast 10.0.2.255
        inet6 fe80::c364:e1b0:d52d:657f  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:77:c5:b8  txqueuelen 1000  (Ethernet)
        RX packets 164217  bytes 182814329 (182.8 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 50303  bytes 6603681 (6.6 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 9297  bytes 817576 (817.5 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9297  bytes 817576 (817.5 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

i changed the network adapter from NAT to bridged adapter. i enter this command to enable it incase it is disabled by default.

ifup enp1s0

got this message:

Unknown interface enp1s0

network adapter

 sudo lshw -C network

*-network                 
       description: Ethernet interface
       product: 82540EM Gigabit Ethernet Controller
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:00:03.0
       logical name: enp0s3
       version: 02
       serial: 08:00:27:77:c5:b8
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm pcix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k8-NAPI duplex=full ip=192.168.1.10 latency=64 link=yes mingnt=255 multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:19 memory:f1200000-f121ffff ioport:d020(size=8)
8
  • cam you post your configuration? atm it's like looking for a needle in a haystack
    – Bart
    Jul 20, 2019 at 7:38
  • /etc/host is set. from virtual settings network adapter is set to bridged adapter and set the adapter. this is the same configurations as i did for kali linux, but with kali i got the result enp1s0. i think maybe mint does not show that property so i searched google about it but could not find anything.
    – Yilmaz
    Jul 20, 2019 at 8:06
  • Do you have any reason why that particular interface should show up? Could you show a bit of configuration?
    – Kusalananda
    Jul 20, 2019 at 8:16
  • 1
    Also, please post the output of sudo lspci -nn -s1:0.0 to verify the type of the network adapter.
    – telcoM
    Jul 20, 2019 at 8:21
  • 1
    Do you have a reason why enp1s0 should exist? Do you have two interfaces?
    – RalfFriedl
    Jul 20, 2019 at 15:06

1 Answer 1

1

If interface is not configured in /etc/network/interfaces it's not shown in ifconfig output by default, but you can check it:

~$: ifconfig -a
~$: ip address show

To check available interfaces:

~$: ls /sys/class/net

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .