2

I have a hard drive sda with 3 OSs:

  • Windows 10
  • Debian
  • Ubuntu

After installing Ubuntu, Debian partition is not showing anymore. I tried to update the grub from Ubuntu:

sudo update-grub

This is the output of this command enter image description here

Debian is correctly detected in the sda6. However it is not displayed in the grub after restarting:

enter image description here

I have two questions:

  1. How can I restore the Debian entry in the grub?
  2. Is it possible to hide the entry sda1 and sda2?

EDIT 1: When I installed Debian I created a separated boot partition. This is the content under this partition:

  • Boot
  • bootmgr
  • BOOTNXT
  • BOOTSECT.BAK
  • '$RECYCLE.BIN'
  • 'System Volume Information'

EDIT 2: After editing "/etc/grub.d/40_custom" with the custom entry:

menuentry 'Debian on /dev/sda6' {
    set root='hd0,gpt6'
    search --fs-uuid --set=root uuid_debian_partition_here
    linux   /boot/vmlinuz-4.9.0-9-amd64 root=UUID=uuid_here ro 
    initrd  /boot/initrd.img-4.9.0-9-amd64        
} 

I see the debian entry in the grub. However after hitting ENTER the following screen is displayed: enter image description here

EDIT 3: This is the content of the mounted partition:

drwxrwxrwx 1 root root   4096 Jul 20 15:21  .
drwxr-xr-x 4 root root   4096 Jul 20 15:03  ..
drwxrwxrwx 1 root root   8192 Jul 17 01:28  Boot
-rwxrwxrwx 1 root root 410802 Jul 17 00:59  bootmgr
-rwxrwxrwx 1 root root      1 Mär 19 05:44  BOOTNXT
drwxrwxrwx 1 root root      0 Jul 20 15:21  boot-repair
-rwxrwxrwx 1 root root   8192 Jul 17 06:00  BOOTSECT.BAK
drwxrwxrwx 1 root root      0 Jul 19 07:39 '$RECYCLE.BIN'
drwxrwxrwx 1 root root      0 Jul 19 05:57 'System Volume Information'
  • (1) Any chance the Debian entry was moved to the "Advanced options"? Check and report if the entry is missing in /boot/grub/grub.cfg. (2) You can hide the windows partitions by setting GRUB_OS_PROBER_SKIP_LIST="UUID_SDA1@/dev/sda1 UUID_SDA2@/dev/sda2" in /etc/default/grub (replace with the real UUIDs and separate both entries with a space), see askubuntu.com/a/514205 – Freddy Jul 19 at 9:23
  • @Freddy There is no grub.cfg file under "/boot/grub" and the entry is not moved to "Advanced options" – birdman Jul 20 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.