0

My understanding of yum is that it should default to installing the latest version of a package available in all the repos enabled. The default repos installed in Amazon Linux 1's AMI include the amzn-main and amzn-updates repos. The latter contains mysql-server which is at 5.5, it also contains mysql57-server.

I am trying to use the geerlinguy.myql Ansible role to install mysql-server which always puts me at 5.5. https://github.com/geerlingguy/ansible-role-mysql/issues/64#issuecomment-512974109

Should yum default to mysql57-server in this case? Or is it because the actual package name has the version in it that it won't work like that?

Can I set yum to point mysql-server > mysql57-server? I am trying to avoid having to patch the Ansible role.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.