1

My laptop is an Acer predator helios 300 with intel i7-7700hq and an NVIDIA GTX 1050ti. It had a 128GB NVME SSD and 1TB hard disk. I had dual boot on it with fedora 29 installed on the SSD and Mint Tessa installed on the Hard Disk. I deleted all the fedora partitions including the EFI partition from within mint using GParted. After that even Mint did not boot up. I tried to install Deepin OS 15.10 on the SSD and freed all the space on the HDD in the process. While the installation completed without an issue, it just freezes completely whenever I hit shutdown or restart. The exact same thing happens with Manjaro Deepin 18.0.2 as well as Elementary OS 5.0 Juno. I tried setting nouveau.modeset=0, acpi=off, acpi=noirq in /etc/default/grub and similar solutions people suggesting online. None of them worked. I then replaced the HDD with a Samsung 860 Evo 250 GB SATA SSD and tried to install Ubuntu 18.04 on it. Exact same thing as the previous three. Clean installation but freezes on reboot/shutdown.

1) I saw people claiming this to be a display driver issue. I am not sure but this seems unlikely as I had faced issues with the nouveau drivers earlier and those mostly led to blank screens on startup. I may be wrong here though.

2) This may be an issue with the UEFI bootloader as on rare occasions when the system does not freeze on pressing shut down immediately, it stops at Problem loading UEFI:db X.509 certificate (-65)

3) I tried some of the UEFI related options like enabling and disabling secure boot. To no avail.

Any help is very very welcome. I am not able to do any work as I don't want to hard shut down my laptop again and again.

0

I'm facing the same issue as you with a laptop ACER Apire VX5-591G series [NVIDA GEFORCE GTX, Intel i7]. I have this problem 2 years ago and tried many different distributions: Manjaro, Debian, Ubuntu, Elementary OS and, in all of them, I had the laptop freezing on shutdown. I tries all the suggestions in changing the acpi mode, editing the grub files, etc. I have installed using the bios legacy mode. In this way, I think it is not a particular problem of UEFI mode. Then I tried Linux Mint 'Sylvia' and it worked perfectly since 2017 until last week when I decided to replace the HD by a SSD Kingston. I tried the new version of Linux Mate 19.1 "Tessa" but the problem came back, it is freeezing on shuting down. The same occurs for the latest versions of Arch Linux, Deepin (15.10.1) and Manjaro 18 (gnome). Finally, I tried the OpenSuse leap and the system is shutting down properly. If you do not care about which distribution to use, I suggest trying OpenSuse leap 15.1 (gnome). I'm new on Linux so I do not know dig into this problem but it seems a comparison between OpenSuse and any of the other OS tried may shed light into this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.