0

I've installed Raspbian Stretch and run the following:

sudo apt-get update
sudo apt-get upgrade

When I try installing syslinux I get this:

$ sudo apt-get install syslinux -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package syslinux is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'syslinux' has no installation candidate

I want syslinux because when I try to run mkwinpeimg I get the following error

$ mkwinpeimg --windows-dir=/mnt/windows7 win7pe.img
ERROR: To make a bootable disk image of Windows PE, we need the "syslinux"
program, but it doesn't seem to be installed.  Please install the "syslinux"
package to continue, or try using the --iso option to make an ISO image instead
of a disk image.

What am I doing wrong?

2

You can install syslinux with

sudo apt-get install syslinux-common -y

If you want to know what the other available packages of syslinux are you can search either by writing sudo apt-get install syslinux and hit TAB a few times or by typing sudo apt search syslinux.

  • Although this maybe "installed" syslinux-common, it still doesn't let me run mkwinpeimg and spits the same error. – gh0st Jul 18 at 23:41
1

The syslinux package is only available for amd64 and i386.

The package wimtools provide the mkwinpeimg command:

sudo apt install wimtools
  • Ah. So what's that mean exactly? It's only available on 64-bit and Itanium chipsets? – gh0st Jul 18 at 23:53
  • @gh0st the syslinux-common can be an alternative as the first proposed answer say. – GAD3R Jul 20 at 17:15
  • 1
    The Debian package syslinux-common is not exactly an alternative for package syslinux. The former contains the components of the SYSLINUX bootloader that can be copied to a media to make it bootable in x86 BIOS style. But to actually install a working SYSLINUX bootloader onto a media in Linux, you'll need to run the /usr/bin/syslinux binary - which is in the latter package, and it is only available for the 64- and 32-bit x86 architectures. Apparently the developer and/or the packager did not expect that someone might want to use ARM hardware to build x86 boot media. – telcoM Jul 20 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.