1

Summary

Recently my RHEL7 workstation at work has been taking a long time (minutes) to go from entering my password on the GUI login screen and my desktop actually appearing.

I would like to know how I go about diagnosing what is causing this.

What I see

Booting to the login screen is as fast as I expect, it's just the login process which is slow.

Sometimes it doesn't even finish logging in before I'm thrown back to the login screen, sometimes it starts up without window decorations and only later do they appear, but most of the time it just takes a long time for my desktop to appear.

What I've tried

I've searched for other people attempting the same investigation and found nothing.

I've looked in /var/log/wtmp, but last just shows that I logged in (or logged in and back out again).

I have tried looking at /var/log/secure, and can see the pam_vas: Authentication <succeeded> lines, and a matching pam_unix(gdm-password:session): session closed for user lines, but there's nothing obviously problematic in between.

I've also looked in /var/log/Xorg.0.log and /var/log/Xorg.0.log.old but there are no EE errors or WW warnings in either.

I've tried looking in ~/.xsession-errors but the lack of time stamps means the messages there are less useful than one might hope, and while there are lots of warnings, the only things which look serious are:

(polkit-gnome-authentication-agent-1:3240): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
...
GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.interface' is not installed
...
###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost

and a bunch of

Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

messages, but non of these seem to be relevant, from the searches that I've made so far.

I've also tried disabling all of my autostart programs, the user theme exntension and removing all non system installed gnome extensions. None of these helped in any way.

What I want

Given how stretched our support team is, I want to try and diagnose as much of this as I can myself, so that even if I can't fix it, I can at least give them a head start.

What I want to know is whether there are any other logs I should be looking at, and what I should be looking for in those log files.

Caveat

I do not have root access to this machine, but I do have limited sudo access. Sadly journalctl is not one of the commands I can run via sudo.

The only window manager option is Gnome (3), the system used to have Gnome Classic too, but that went away with an update. My home directory is on an nfs share, accessed by GigE, and the machine has 32GB memory, NVMe storage and Quadro P1000 graphics, if any of that might be relevant.

0
+50

Information above is not enough to understand root cause of the problem. One of the appoaches to this I would try:

Login to text console as your user. Do

for((;;)); do ps aux --forest; sleep 0.5s; done >audit

Watch the processes being executed. Find diffs relevant to your session, there should be something not changing for all this minutes. Look into that specific script or binary and identify reason.

  • Didn't really help, but at least you bothered to try. *8') – Mark Booth Sep 13 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.