0

As the title says, zsh crashes when writing to a rust .rs file using vim. It crashes whenever I save the file using :w.

It never crashes when I edit another filetype (I've tried .c, .js, .py). I'm guessing that it has something to do with some kind of filewatcher. I noticed it while going through the rustlings exercises and have a hunch it has to do with the rustlings watch but I'm having trouble getting rid of this issue.

The error:

[1]  + 1858 suspended (tty output)  vim main.rs
khuynh@kmbp:~ $ 
zsh: error on TTY read: Input/output error

[Process completed]

vim --version

VIM - Vi IMproved 8.0 (2016 Sep 12, compiled Feb 22 2019 19:03:04)

zsh --version

zsh 5.3 (x86_64-apple-darwin18.0)

Any help is appreciated, thanks!

EDIT: solved my issue. was a problem with the rust.vim plugin in my .vimrc

0

Found the issue, it seemed to be an issue in my .vimrc, specifically with the rust.vim plugin.

In my .vimrc, I commented out the plugin and editing .rs files no longer crashes my shell!

Plug 'scrooloose/nerdtree'
" rust plugin crashes zsh when writing .rs files
" Plug 'rust-lang/rust.vim'
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.