1

I am using Ubuntu 18LTS. I am making changes to

enter image description here

file located in /usr/bin/ but after reboot it came back as before and also the last modification date, so from that rises my question: what does this "*" means at beginning of file name in Midnight Commander?

Cause I can not modify it permanently. Thanks in advance.

  • 2
    Possible duplicate of What does * next to the file name mean in the output of ls? – muru Jul 17 '19 at 4:29
  • try \ls (a backslash preceeding ls) to get rid of * . – Archemar Jul 17 '19 at 4:39
  • 3
    @muru ls -F will append, not prepend a * indicator to filenames which refer to executables. – mosvy Jul 17 '19 at 18:37
  • 1
    @duplicate ... ... How could a Midnight Commander panel be identical to an ls output ? – Isaac Jul 17 '19 at 21:25
1

Assuming you're using Midnight Commander as was guessed based on the image, MC's man page says under "Listing Mode...", that one of the available fields is this:

type

displays a one character wide type field. This character is similar to what is displayed by ls with the -F flag - * for executable files, / for directories, @ for links, = for sockets, - for character devices, + for block devices, | for pipes, ~ for symbolic links to directories and ! for stale symlinks (links that point nowhere).

Underneath, it's mentioned that

For example, the Full display corresponds to this format:

half type name | size | mtime

which pretty much looks like what I get by default, so it's probably just the type indicator for an executable file.

You could test that empirically too, just create a directory with a bunch of different kinds of files and see what MC shows you.

  • There is no assumption. The OP explicitly asks: * what does this "" means at beginning of file name in Midnight Commander? – Isaac Jul 17 '19 at 21:23
  • @Isaac, well, if you look at the edit history, that's not OP's text, mosvy inserted that part in there, based on the pic. Though now I notice there's also a mention of a comment, and there's one mentioning MC under the other answer. – ilkkachu Jul 18 '19 at 5:49
  • Yes, you are correct in all counts. The original source is a comment, but, it is from the OP (original poster) anyway. Thanks for your review. – Isaac Jul 18 '19 at 18:10
0

It looks like you have specified the -F option in your ‘ls’ command, showing that the file is executable. This may be a setting in your .bashrc file, or another config file that your shell is reading. When using the -F option with ls it provides the following:

/: directories
@: symbolic links
|: FIFOs
=: sockets
*: executable files

Is it just that one file you are trying to delete that comes back after a reboot or all files?

  • Thanks!. I am modifying not deleting the file. I was using midnight commander and it seems it shows symbols as default. So it is an executable python script, but my modification vanished after reboot, could this be due to file type or file location? – greinaovester Jul 17 '19 at 5:00
  • It may be that your Ubuntu is using RAMDISK to mount / which would include /use/bin. In this case the directory is loaded in to RAM, hence any modification you make to the file is lost once you reboot the device as it was written to RAM rather than your HD. – am401 Jul 17 '19 at 5:15
  • OK I will search about this subject and open a new thread if needed. Thanks again. – greinaovester Jul 17 '19 at 5:33
  • There is no ls command used. It is an MC (midnight commander) panel list. – Isaac Jul 17 '19 at 21:21
  • Initial question (pre editing) indicated that ls had been used and had no mention of MC, therefore my answer had relevancy at that point. Thank you though for the clarification. – am401 Jul 17 '19 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.