0

For some reason, we noticed two physical interfaces (eth0, eth3) are under the same bridge vmeth0. We need to remove eth3 from vmeth0 bridge without affecting the rest of the configuration. Please advise any instruction to make this possible?

We are using Linux (Redhat -release 6.8)

# brctl show
bridge name     bridge id               STP enabled     interfaces
vmbondeth0              8000.0010e0cdc56b       no              bondeth0
                                                        vif90.1
vmeth0          8000.0010e0cdc56a       no              eth0
                                                        eth3
                                                        vif90.0
  • @Janka, will it only remove eth3 from the bridge? Or will it remove the vmeth0 as well? – user1595858 Jul 16 '19 at 23:24
  • Thanks that helps to remove the interface which answers my question. I believe we have configured a interface bridge name wrongly which caused this issue and we have corrected it. If we now create a new bridge ex. vmeth3 for interface eth3, we don't see the virtual interface created. Should we need to restart the server? Please post your previous answer so we can select as our answer to our question. – user1595858 Jul 16 '19 at 23:36
  • Done, and no, you don't have to restart the server. But you could restart the network service and see if the wrong setting reappears. (This also removes the wrong bridge configuration once you have configured the files correctly.) – Janka Jul 17 '19 at 11:40
0

The command

# brctl delif vmeth0 eth3

will remove the interface eth3 from the bridge vmeth0. See the brctl manpage, e.g. here for more details.

Please note this command only affects the current bridge settings in the kernel. If you have configured your bridge wrong in the configuration files of your distribution, the wrong setting will reappear as soon you restart the network, e.g. on reboot.

For RedHat Linux, the relevant documentation about the configuration files is here.

You have to restart the network service to apply those settings from the configuration files.

# systemctl restart network

should do the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.