3

Recently I upgrade Debian on my laptop from Stretch to Buster. I noticed some problems (some apps stopped working, there was no drag 'n drop, Nvidia 3D card was not functional, etc), so I searched the Internet and realized it was related to Wayland. Since then, I've run Gnome on Xorg.

Everything looks fine now, except the middle-click. Clicking on mouse wheel doesn't work anymore.

I searched the Internet again and all answers I found say about checking org/gnome/settings-daemon/peripherals/mouse/middle-button-enabled in dconf-editor or edit /etc/X11/xorg.conf directly.

Unfortunately, in my dconf-editor there's no middle-button-enabled in org/gnome/settings-daemon/peripherals/mouse/ And also there's no xorg.conf at /etc/X11/

What else can I do to re-enable/reactivate middle-click?

P.S.: Touchpad seems to be working fine (clicking on both buttons acts as a middle-click on most app, triple touch on touchpad as well).


[edit¹]
I unplugged and plugged mouse usb again and then dmesg showed:

vinicius@Menbung:~$ sudo dmesg
[ 1011.128101] usb 1-2: USB disconnect, device number 8
[ 1020.383018] usb 1-2: new full-speed USB device number 9 using xhci_hcd
[ 1020.537022] usb 1-2: New USB device found, idVendor=046d, idProduct=c52f, bcdDevice=30.00
[ 1020.537024] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1020.537025] usb 1-2: Product: USB Receiver
[ 1020.537026] usb 1-2: Manufacturer: Logitech
[ 1020.540971] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:046D:C52F.0007/input/input28
[ 1020.541080] hid-generic 0003:046D:C52F.0007: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:14.0-2/input0
[ 1020.542265] input: Logitech USB Receiver Consumer Control as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.1/0003:046D:C52F.0008/input/input29
[ 1020.599128] hid-generic 0003:046D:C52F.0008: input,hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-2/input1


[edit²]
I thought I had solved the issue...

At first, I searched Internet to find my xorg.conf, which I think wayland hid. I didn't find it, but I found something I thought was somewhat equivalent (based on xorg.conf manpage): /usr/share/X11/xorg.conf.d/40-libinput.conf. Then I added to the end of this file (based on this thread and this FAQ):

Section "InputClass"
    Identifier "middle button emulation class"
    MatchIsPointer "on"
    Option "Emulate3Buttons" "on"
EndSection

At first apparently it didn't work.

So I decided to install xinput package from debian repositories.

Found my mouse on $ xinput list, then listed its properties $ xinput list-props 10 (10 is my device id) and this line caught my attention:

    libinput Middle Emulation Enabled (297):   0

I simply changed 0 to 1:

$ xinput set-prop 10 "libinput Middle Emulation Enabled" 1

Again, at first apparently it didn't work. Then I try it with sudo. No effect. But I realized something happened, the middle-click sometimes worked sometimes not. Then I found this: "Make sure "Middle Mouse Button Emulation" is disabled or you'll get 50ms left-click latency".

I changed back libinput Middle Emulation Enabled (297) to 0.

The latency was gone.

But after a while, middle-click simply stops working, until I change libinput Middle Emulation Enabled (297) to 1 (and middle-click works with latency) and again to 0 (when latency stops)... after a while middle-click stops working again.

  • Any errors in dmesg when you try to middle click? – Chuck Horowitz Jul 16 '19 at 20:47
  • @ChuckHorowitz I edited the question to show what dmseg says about the mouse. No error. I don't know if I use dmseg right, mouse clicks don't change dmseg info. – MarvinMep Jul 19 '19 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.