0

i changed my yum repository to /media and mounted iso of CentOS-7-x86 to /media and used yum install packagename to install packages with dependencies, got no errors but when i tried to install gcc i got this error:

--> Finished Dependency Resolution
Error: Package: glibc-headers-2.17-260.el7.x86_64 (c7-media)
       Requires: glibc = 2.17-260.el7
       Installed: glibc-2.17-260.el7_6.5.i686 (@updates)
           glibc = 2.17-260.el7_6.5
       Available: glibc-2.17-260.el7.x86_64 (c7-media)
           glibc = 2.17-260.el7
Error: Package: glibc-devel-2.17-260.el7.x86_64 (c7-media)
       Requires: glibc = 2.17-260.el7
       Installed: glibc-2.17-260.el7_6.5.i686 (@updates)
           glibc = 2.17-260.el7_6.5
       Available: glibc-2.17-260.el7.x86_64 (c7-media)
           glibc = 2.17-260.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

i don't know how to solve this or why i get error.
the version of OS is: centos-release-7-6.1810.2.el7.centos.x86_64
what should i do?

2

You have packages from the 'updates' repository installed, which are newer than what's on the ISO media, which only has packages from the original date of that point release. Yum can't get the dependencies (since it appears you've turned off updates), because the updated glibc package requires you install glibc-headers of the same release, which is not available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.