0

I need to find the following information of IBM Power8 running Linux:

  1. Processor type
  2. Model Name
  3. Processor speed

Following is the required output (came from another source called BigFix) :

"IBM(R) POWER8(R) MODEL 9009-42A REV 2.1 @ 3026.000000MHZ RUNNING AS POWER8"

I have tried different commands but nothing returns such output. Following are the commands I have tried so far :

  1. dmidecode
  2. lshw
  3. /proc/cpuinfo
  4. lscpu
  5. unman -a
  6. ppc64_cpu
3
  • 1
    Instead of "size", you might have meant "speed"?
    – Jeff Schaller
    Jul 15, 2019 at 9:50
  • yes exactly "speed". Thanks for correction. Jul 16, 2019 at 12:27
  • I've edited your question to change "size" to "speed". You're also able to edit your question, as needed.
    – Jeff Schaller
    Jul 16, 2019 at 13:18

1 Answer 1

1

You could use the nmon.

By opening nmon and then use the r option for Resources Linux & Processor will provide the information for CPU. Note that nmon needs to be installed separately as its not out of the box utility in Linux.

E.g:

x Resources Linux & Processor 
x    Linux: Linux version 3.10.0-957.21.3.el7.ppc64le ([email protected])      
x    Build: (gcc version 4.8.5 20150623 (Red Hat 4.8.5-36) (GCC) )                                      
x    Release  : 3.10.0-957.21.3.el7.ppc64le                                                             
x    Version  : #1 SMP Fri Jun 14 06:58:05 UTC 2019                                                     
x    cpuinfo: cpu  : POWER8 (architected), altivec supported                                            
x    cpuinfo: clock  : 4024.000000MHz                                                                   
x    cpuinfo: revision : 2.0 (pvr 004d 0200)                                                            
x    cpuinfo: machine  : CHRP IBM,9080-MME                                                              
x    # of CPUs: 16al CPU:2 & Logical CPU:16  Little Endian                                              
x    Machine  : ppc64le                                                                                 
x    Nodename : rhel7poc                                                                                
x    /etc/*ease[1]: NAME="Red Hat Enterprise Linux Server"                                              
x    /etc/*ease[2]: VERSION="7.6 (Maipo)"                                                               
x    /etc/*ease[3]: ID="rhel"                                                                           
x    /etc/*ease[4]: ID_LIKE="fedora"                                                                    
x    lsb_release: not found                                                                             
x    lsb_release: (null)                                                                                
x    lsb_release: (null)                                                                                
x    lsb_release: (null)
3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .