0
> man ls
No manual entry for ls

> man tar
No manual entry for tar

Every command cannot be found, except Git. I installed git a while ago and had trouble getting the git man to show up. I forget what I did and, now git can be found and every else cannot be found. I have tried yum update, install for man and man-pages. I think the problem is just assigning the correct path for man to find the pages. No sure how to do that. I'm using CentOS 7.

Some info...

> man -w
/usr/local/share/man:/usr/share/man

> man -w git
/usr/local/share/man/man3/Git.3pm
  • 1
    May need to change MANPATH, as suggested here... linuxquestions.org/questions/linux-newbie-8/… – David Yockey Jul 12 at 18:25
  • @DavidYockey I have tried that and has not worked. – Norman Potts Jul 12 at 19:59
  • @sourcejedi sorry about the mistake. The it has the e. – Norman Potts Jul 12 at 20:15
  • 1
    What is the output of command man? Do you still have /usr/share/man/man1/ls.1.gz? If so, what happens if you run man -l /usr/share/man/man1/ls.1.gz? – sourcejedi Jul 12 at 20:17
  • lol they work with sudo... hmm – Norman Potts Jul 12 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.