14

Please, how to get rid of IBus service/IBus panel when running KDE?

This Gnome(?) keyboard layout manager (?) can get into conflict with the layout set natively in KDE Settings. I need to switch often between CZ and UK keyboard and IBus makes it impossible.

The severity of this issue can range from a visual irritation of having two keyboard layout indicators in the tray area, but it gets much more serious when both systems set conflicting layouts; like when in KDE I set Czech keyboard but IBus somewhat keeps English UK layout:

enter image description here

enter image description here

enter image description here

Can you guess which layout - EN (IBus) or CZ (KDE) - is actually active? The wrong one, of course, IBus seems to always override KDE :(

If I quit IBus panel now, it would make it even worse because it's only the tray applet, the GUI bit, what disappears but IBus service is still active. I still wouldn't have my CZ keyboard and absolutely no way to change it.

Very annoying variant of this problem is when user have only single layout setting in KDE, which is by default not displayed in the tray area; but IBus setting always is, even as single layout. User then have a very angrying sensation of whatever he sets in KDE Settings is completely ignored, blaming probably KDE, unaware that the layout indicator belongs to a different system and that is overriding KDE settings.

I once managed to kill all keyboard input completely when playing with KDE Settings and IBus properties at the same time. Really awful UX.

IBus seems to be part of the Gnome stack. So why it gets activated in KDE? I suspect it appeared there only after I had installed also some Gnome/Gtk applications, like Gimp, GDM, etc.

OS: openSuse 15.0 Linux. This issue was present in previous versions too.

UPDATE:

I also faced issue with US keyboard suddenly appearing as a third option. But twat would be for yet another bug report.

UPDATE 2:

OK, I uninstalled them. Surprisingly it is possible to uninstall just ibus, not the whole Gnome. My GDM still works. BUT - I now face another issue, I cannot switch keyboard layouts anymore, despite setting everything in System Settings and having 2 keyboard indicators in tray, only UK keyboard now works for me. I suspect IBus screwed something in KDE generally.

Ehhh, I sometimes feel that working with Linux means you will spend half of the time solving usability issues and writing bug reports :(

4 Answers 4

5

There is an easier way to prevent irritations while also keeping Zoom and ibus installed: Just instruct ibus to use your XKB keyboard layout.

Right-click the ibus widget, go to Preferences -> Advanced and check "Use system keyboard layout". Now ibus should follow whatever layout you've set in Plasma.

1
  • Thanks for this tip. The best solution in my opinion.
    – Paidhi
    Feb 27 at 7:16
4

I had a similar issue, though possibly slightly different as I don't intend to keep using Gnome.

Removing ibus-gtk, ibus-gtk3, ibus-gtk3-32bit, ibus-lang, and ibus (all ibus-related packages on my system; yours may be different) seems to have worked with no ill effects after a reboot.

You can remove them by running zypper rm -u ibus* - be sure to check the list for anything essential that you do not want removed.

2
  • OK, I uninstalled them. Surprisingly it is possible to uninstall just ibus, not the whole Gnome. My GDM still works. BUT - I now face another issue, I cannot switch keyboard layouts anymore, despite setting everything in System Settings and having 2 keyboard indicators in tray, only UK keyboard now works for me. I suspect ibus screwed something in KDE generally.
    – Espinosa
    Aug 23, 2019 at 23:16
  • Update on the message above. Apparently this is caused by VNC, not KDE or iBUS. I was connecting remotely by VNC and VNC takes your local, in my case Windows OS, keyboard settings and applies them to the remote session. And it cannot be efectively switched!
    – Espinosa
    Dec 21, 2020 at 21:13
1

I've been using KDE for some time now and I faced the same problem, having to keyboards managers IBus and the default module Keyboard of KDE. Also two managers seemed to interfered with each other. At the beginning I thought that my laptop keyboard had problems, because in some cases it did not correctly detect the key pressed. The solution that works for me was uninstall IBus:

:~> sudo zypper rm ibus

Reading installed packages...
Resolving package dependencies...

The following 6 packages are going to be REMOVED:
ibus ibus-gtk ibus-gtk3 ibus-lang ibus-m17n

Consider check the packages that are going to be removed, you must make sure that only ibus* related packages are selected.

Hope this help

1

While it's the dependency of Zoom application it's impossible to simply remove.

The solution is:

  1. Right click on the panel and select "Edit Panel"
  2. Right click on the System Tray and select "Configure"
  3. In the System Tray Setting find IBus Panel and change the select box to "Always hidden"
1
  • 1
    This will not help in the case of conflicting layouts between ibus and XKB. But making ibus recognize the XKB layout should work.
    – Ramón
    Feb 22, 2021 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.