Please, how to get rid of IBus service/IBus panel when running KDE?

This Gnome(?) keyboard layout manager (?) can get into conflict with the layout set natively in KDE Settings. I need to switch often between CZ and UK keyboard and IBus makes it impossible.

The severity of this issue can range from a visual irritation of having two keyboard layout indicators in the tray area, but it gets much more serious when both systems set conflicting layouts; like when in KDE I set Czech keyboard but IBus somewhat keeps English UK layout:

enter image description here

enter image description here

enter image description here

Can you guess which layout - EN (IBus) or CZ (KDE) - is actually active? The wrong one, of course, IBus seems to always override KDE :(

If I quit IBus panel now, it would make it even worse because it's only the tray applet, the GUI bit, what disappears but IBus service is still active. I still wouldn't have my CZ keyboard and absolutely no way to change it.

Very annoying variant of this problem is when user have only single layout setting in KDE, which is by default not displayed in the tray area; but IBus setting always is, even as single layout. User then have a very angrying sensation of whatever he sets in KDE Settings is completely ignored, blaming probably KDE, unaware that the layout indicator belongs to a different system and that is overriding KDE settings.

I once managed to kill all keyboard input completely when playing with KDE Settings and IBus properties at the same time. Really awful UX.

IBus seems to be part of the Gnome stack. So why it gets activated in KDE? I suspect it appeared there only after I had installed also some Gnome/Gtk applications, like Gimp, GDM, etc.

OS: openSuse 15.0 Linux. This issue was present in previous versions too.


I also faced issue with US keyboard suddenly appearing as a third option. But twat would be for yet another bug report.


OK, I uninstalled them. Surprisingly it is possible to uninstall just ibus, not the whole Gnome. My GDM still works. BUT - I now face another issue, I cannot switch keyboard layouts anymore, despite setting everything in System Settings and having 2 keyboard indicators in tray, only UK keyboard now works for me. I suspect IBus screwed something in KDE generally.

Ehhh, I sometimes feel that working with Linux means you will spend half of the time solving usability issues and writing bug reports :(


6 Answers 6


There is an easier way to prevent irritations while also keeping Zoom and ibus installed: Just instruct ibus to use your XKB keyboard layout.

Right-click the ibus widget, go to Preferences -> Advanced and check "Use system keyboard layout". Now ibus should follow whatever layout you've set in Plasma.

  • Thanks for this tip. The best solution in my opinion.
    – Paidhi
    Commented Feb 27, 2022 at 7:16
  • If the problem is that zoom requires ibus (but not other package requires it), then it's actually possible to remove ibus from zoom's requirements by editing the package, cf. hashman.ca/zoom It does'nt change the behavior of zoom at all, so removing ibus, editing zoom and leaving it at that is IMHO the best solution.
    – Clément
    Commented Aug 31, 2023 at 14:09

I had a similar issue, though possibly slightly different as I don't intend to keep using Gnome.

Removing ibus-gtk, ibus-gtk3, ibus-gtk3-32bit, ibus-lang, and ibus (all ibus-related packages on my system; yours may be different) seems to have worked with no ill effects after a reboot.

You can remove them by running zypper rm -u ibus* - be sure to check the list for anything essential that you do not want removed.

  • OK, I uninstalled them. Surprisingly it is possible to uninstall just ibus, not the whole Gnome. My GDM still works. BUT - I now face another issue, I cannot switch keyboard layouts anymore, despite setting everything in System Settings and having 2 keyboard indicators in tray, only UK keyboard now works for me. I suspect ibus screwed something in KDE generally.
    – Espinosa
    Commented Aug 23, 2019 at 23:16
  • Update on the message above. Apparently this is caused by VNC, not KDE or iBUS. I was connecting remotely by VNC and VNC takes your local, in my case Windows OS, keyboard settings and applies them to the remote session. And it cannot be efectively switched!
    – Espinosa
    Commented Dec 21, 2020 at 21:13
  • I'm on linux mint and the zypper command didn't work. After launching Synaptic Package Manager from the main menu, I filtered for ibus and "completely removed" all packages who's name begins with ibus. Did a reboot and it seems to have worked great.
    – maninak
    Commented Oct 20, 2022 at 14:54

While it's the dependency of Zoom application it's impossible to simply remove.

The solution is:

  1. Right click on the panel and select "Edit Panel"
  2. Right click on the System Tray and select "Configure"
  3. In the System Tray Setting find IBus Panel and change the select box to "Always hidden"
  • 3
    This will not help in the case of conflicting layouts between ibus and XKB. But making ibus recognize the XKB layout should work.
    – Ramón
    Commented Feb 22, 2021 at 12:07
  • While keeping Zoom installed, removing the im-config package might be enough.
    – Olivier
    Commented Nov 21, 2023 at 16:36

I've been using KDE for some time now and I faced the same problem, having to keyboards managers IBus and the default module Keyboard of KDE. Also two managers seemed to interfered with each other. At the beginning I thought that my laptop keyboard had problems, because in some cases it did not correctly detect the key pressed. The solution that works for me was uninstall IBus:

:~> sudo zypper rm ibus

Reading installed packages...
Resolving package dependencies...

The following 6 packages are going to be REMOVED:
ibus ibus-gtk ibus-gtk3 ibus-lang ibus-m17n

Consider check the packages that are going to be removed, you must make sure that only ibus* related packages are selected.

Hope this help


One option is to disable IBus at the user level (the default input manager should then be used) by having the line

run_im none

in the file ~/.xinputrc.


The reason ibus is installed is (on my system and according to other answers here) that it is a dependency of Zoom.

I’ve found (on OpenSUSE Tumbleweed with KDE) that you can remove ibus nonetheless, breaking the declared zoom dependencies, and everything still works fine. You can do that with addlock (al) and removelock (rl) commands:

sudo zypper al zoom  # forbid uninstalling zoom
sudo zypper rm ibus  # prompts for resolution, pick “break zoom-* by ignoring some of its dependencies”
sudo zypper al ibus* # forbid reinstalling ibus
sudo zypper in zoom  # declare we want to keep zoom even without lock
sudo zypper rl zoom  # remove lock on zoom so we can upgrade later

The only subtlety is to attempt to re-install zoom after removing ibus, so that when you remove the zoom lock, zypper doesn’t automatically ask to remove zoom.

It seems zoom is no less stable than with ibus installed, and ldd on the binaries under /opt/zoom does not show “not found” entries for ibus libraries.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .