1

As will hopefully become clear, I don't really know what I'm doing, so apologies for any stupidity below and please don't assume any background knowledge that isn't implicit in what I've already done (even then, probably best to err on the side of caution).


I'm running Mint 18 64-bit with MATE, Winehq-staging 4.12.1~xenial. My graphics hardware is Intel's HD graphics 510 iGPU.

When starting the Battle.net application I can log in, and the application apparently runs fine, e.g. downloading and installing games; but the contents of the main window are not shown apart from certain mouseover information (about game installation progress) and the cursor, which does change type according to where it's positioned in the window.

The window is black at first; if I open another application then return to Battle.net, it shows a fixed image of whatever was behind it, then returns to black if I move the window. I can access Settings and other windows by right-clicking the Battle.net icon in the notification area of the MATE taskbar.

When running from the terminal, I get a lot of fixme messages along with a few basic types of error:

00bb:err:vulkan:wine_vkCreateInstance Failed to create instance, res=-9
[0711/165930.162:ERROR:gpu_process_transport_factory.cc(1031)] Lost UI shared context.
[0711/165934.016:ERROR:command_buffer_proxy_impl.cc(130)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.

These are the main ones, but I've also seen

[0710/231759.122:ERROR:command_buffer_proxy_impl.cc(111)] ContextResult::kFatalFailure: Shared memory region is not valid
[0710/231900.486:ERROR:latency_info.cc(144)] Surface::TakeLatencyInfoFromFrame, LatencyInfo vector size 101 is too big.
0035:err:ole:CoCreateInstanceEx apartment not initialised
[0711/221922.748:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8

I've tried a few things, some of which might have made things worse.

From WineHQ:

  • disabling browser hardware acceleration
  • killing Agent.exe

From the Lutris github page (I am not using Lutris):

  • deleting the cache folders under Application Data
  • disabling streaming
  • checking 32-bit architecture is enabled for Wine
  • checking that I'm launching from Battle.net.exe rather than Battle.net Launcher.exe
  • installing all libraries recommended for my setup (libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386)
  • installing Padoka (stable), which includes Vulkan drivers; then removing it, because it was designed for Ubuntu 18.04 and Mint 18 is based on Ubuntu 16.04; but apparently I still have some Vulkan drivers on my system anyway (mesa-vulkan-drivers mesa-vulkan-drivers:i386)

None of these seems to have done anything.

In particular, the last one has me confused. When I look online for information about Vulkan drivers, I find things for Nvidia or AMD graphics cards (Mesa seems to be for the latter). I have neither, and what's more Intel's iGPUs have only started supporting Vulkan quite recently... but I think some people are running Battle.net on systems with iGPUs anyway, so I really don't know what to conclude.

When I run vulkaninfo | grep --ignore-case err I get

ERROR: [loader] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
ERROR: [loader] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32

I've started trying to look into this, but beginning to get lost.

Is it possible to get Vulkan working properly with my old iGPU? If not, can I still get Battle.net to work?

1

I have the same problem on Debian: dark screen in Battle.net, but not only there. From what I gather, Wine staging 4.12.1 seems to have issues...

Try downgrading back to 4.11 a see if it helps.

  • Thanks, I switched to winehq-stable and this seems to have fixed it. Actually I reinstalled the operating system first (was losing track of what else I might have messed up) and moved to Mint 19 while I was at it, but the same problem was still happening with the latest version of winehq-staging, and the switch to winehq-stable sorted it. – Robin Saunders Jul 13 at 4:03
  • Also, it looks like winbind is needed (at least for some of the games) but not included with Wine. – Robin Saunders Jul 13 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.