0

I have this laptop - HP Spectre x360 13-w023dx.

Basically my headphones work in Windows but they don't work in Linux (specifically Arch Linux). In Linux, my headphones are detected (i.e. the system volume changes when I connect my headphones) but I can't seem to get any audio to play out at all.

I have tried audio when booting from an Ubuntu Live CD and it still doesn't work.

I've tried hdajackretask and following this, but all it does is play audio through the speakers like nothing was connected to the headphone jack at all.

Also, playing audio via a USB-C audio interface only works in Windows, a similar problem happens when playing in Linux.

Here is the output of pactl list sinks when the headphones are connected, if it helps:

Sink #0
        State: SUSPENDED
        Name: alsa_output.pci-0000_00_1f.3.analog-stereo
        Description: Built-in Audio Analog Stereo
        Driver: module-alsa-card.c
        Sample Specification: s16le 2ch 48000Hz
        Channel Map: front-left,front-right
        Owner Module: 6
        Mute: no
        Volume: front-left: 16381 /  25% / -36.13 dB,   front-right: 16381 /  25% / -36.13 dB
                balance 0.00
        Base Volume: 65536 / 100% / 0.00 dB
        Monitor Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
        Latency: 0 usec, configured 0 usec
        Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
        Properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC295 Analog"
                alsa.id = "ALC295 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xdc228000 irq 134"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "9d71"
                device.product.name = "Sunrise Point-LP HD Audio"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Realtek ALC295"
                alsa.components = "HDA:10ec0295,103c827e,00100002 HDA:8086280b,80860101,00100000"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Ports:
                analog-output-speaker: Speakers (priority: 10000, not available)
                analog-output-headphones: Headphones (priority: 9000, available)
        Active Port: analog-output-headphones
        Formats:
                pcm

Any help to get my headphones to work (and also USB-C audio) would be appreciated. Thanks!

1

there is an audio codec 'fixup' for this laptop use this command in terminal

echo 'options snd-hda-intel model=alc295-hp-x360' | sudo tee --append /etc/modprobe.d/alsa-base.conf

this creates a file alsa-base.conf (file name can be anything, but must end in '.conf' in /etc/modprobe.d/ folder)

reboot to load laptop model configuration for audio driver

  • I saw this fix online and I tried it but it didn't work. Still no audio through headphones. – etnguyen03 Jul 12 at 12:08
  • @etnguyen03: Look through dmesg after to boot to verify that your kernel is new enough to recognize the model option and apply the fix. If it doesn't, switch to a newer kernel. – dirkt Jul 13 at 5:09
  • @dirkt dmesg | grep hda doesn't mention anything about the alc295-hp-x360 fix, all that I see is here. – etnguyen03 Jul 15 at 13:07
  • Then I'd assume it's not new enough. – dirkt Jul 15 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.