1

I have been trying to install ROS Kinetic for my Raspberry Pi 3 for the past few weeks, but have been encountering numerous problems. The most recent problem is that I am trying to build my catkin workspace, but I found that the error is occurring with Cmake. It kept giving me an error message detailing about how it can't find bzip2. After some research, I figured that I needed to install libbz2-dev in order to create the header files necessary for Cmake to recognize bzip2.

But when I try to run:

$ sudo apt-get install libbz2-dev

It returns this message:

Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf bzip2-doc all 1.0.6-9
  404  Not Found [IP: 93.93.128.193 80]
Err:2 http://raspbian.raspberrypi.org/raspbian buster/main armhf libbz2-dev armhf 1.0.6-9
  404  Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/b/bzip2/bzip2-doc_1.0.6-9_all.deb  404  Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/b/bzip2/libbz2-dev_1.0.6-9_armhf.deb  404  Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I cannot find any resources anywhere to help me understand why the links aren't working, so I am posting here for help. Please let me know if I need to provide any other information.

2

Both files are present with suffix 1.0.6-9.1 instead of 1.0.6-9:

http://raspbian.raspberrypi.org/raspbian/pool/main/b/bzip2/bzip2-doc_1.0.6-9.1_all.deb http://raspbian.raspberrypi.org/raspbian/pool/main/b/bzip2/libbz2-dev_1.0.6-9.1_armhf.deb

You can browse the folder here:

http://raspbian.raspberrypi.org/raspbian/pool/main/b/bzip2/

It seems that your package index is not up-to-date, just as the error message suggests. Please try:

sudo apt-get update
sudo apt-get install libbz2-dev
  • I had already run apt-get update before to make sure, but it seems like the index is not working for the packages even though its up to date. I fixed it by manually downloading the files, transferring the files to the Pi, and unpacking them using dpkg. Thank you for your help! – jekthewarrior Jul 10 at 4:06
1

I had the same problem, and when I ran apt-get update it would give warnings like:

E: Repository 'http://security.debian.org/debian-security buster/updates InRelease' 
  changed its 'Suite' value from 'testing' to 'stable'
N: This must be accepted explicitly before updates for this repository can be applied. 
  See apt-secure(8) manpage for details.

fixing that, by running apt-get update --allow-releaseinfo-change as suggested here https://superuser.com/questions/1456989/how-to-configure-apt-in-debian-buster-after-release seemed to fix my libbz2-dev installing issues as well.

  • I wish I could mark both answers as the answer. I tried using the solution and it worked! Thank you. – jekthewarrior 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.