0

I'm currently trying to bypass browser security, by hosting a static html page under all (external) domains.

e.g.

Given a webpage hosted at http://myinternalserver/mypage.html
When I request https://www.google.com/mypage.html via the proxy
Then my webpage is displayed.

I've added the following snippet to my squid.conf, however the content isn't being intercepted (I get 404 Not Found from target site).

What am I doing wrong?

squid.conf

# reverse proxy /mypage* requests to internal server
acl myrule urlpath_regex ^/mypage

cache_peer myinternalserver parent 80 0 no-query originserver name=server1 
cache_peer_access server1 allow myrule 
cache_peer_access server1 deny all 

I've tried turning on detailed logging, but I can't see myrule being checked (it's never logged). Is the ACL not being picked up? Do I have to enable urlpath_regex? Is is a compile option for Squid?

Squid Version

Related:

Update:

I found (and commented out) the following line - so now the reverse proxy works for HTTP requests. Just need to get it working with HTTPS...

# vvv WARNING: THIS WILL SKIP cache_peer DIRECTIVES vvv
# always_direct allow all

Full disclosure, I've also posted in serverfault - will close whichever receives the least attention.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.