1

i installed xsnow & xpenguins program but none of them work for me. i find out they need main root window (or root x window) to work which is "probably" invisible in my OS or is not available. how can i make them work fine in my Operation system (by recompiling them or any other thing)? the output of "uname -r" is:

4.19.45-1-MANJARO

i hope asked my question in the right place otherwise please introduce a link to search for solution

1

There is a new version of xsnow available, which works in most desktop environments. This version is available in debian-testing and the latest version is on sourceforge:

https://sourceforge.net/projects/xsnow/

| improve this answer | |
  • Thank you, but unfortunately i am on manjaro which is arch based and not debian based:( I wish xsnow be available for manjaro one day. I love it very much. – milad Oct 17 '19 at 11:30
0

I tested the newest version of xsnow in a virtual machine with manjaro xfce 18.1.1-191015 : from https://sourceforge.net/projects/xsnow/files/ download xsnow-2.0.13.tar.gz , then:

tar xf xsnow-2.0.13.tar.gz cd xsnow-2.0.13 ./configure make sudo make install

If everything went ok, xsnow is now installed as /usr/local/games/xsnow . In Manjaro this is not optimal, but you can easily correct this:

ln -sf /usr/local/games/xsnow /usr/local/bin/xsnow

With standard settings, xsnow runs very badly on my virtual machine, I had to start xsnow like:

xsnow -alpha 0 -exposures

Note that xsnow keeps it's configuration in ~/.xsnowrc , so the next invocation does not need the flags.

Note: in manjaro-kde (manjaro-kde-18.1.1-191015-linux53) xsnow runs with default settings in a virtual machine.

xsnow running in manjaro

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.