0

I have a Dell inspiron 7720 notebook. There is also small subwoofer on it but worked well only left and right side of speakers on ubuntu 18.04.2. Then I used these steps:

sudo nano /etc/pulse/daemon.conf

I uncommmented and changed the values of these lines:

enable-lfe-remixing = yes default-sample-channels = 3 default-channel-map = front-left,front-right,lfe

Then I edited the following file: sudo nano /etc/pulse/default.pa

Added the following line to the end:

load-module module-combine channels=3 channel_map=front-left,front-right,lfe

After restart I saw in sound settings new option for subwoofer and when I pushed Test sound button, nothing happened. Then I used hdajackretask and overwrote the pin ID 0x10 with Internal Speaker (LFE). Install boot override and restarted notebook. I went back to sound settings and when I tested subwoofer ubuntu gave me back whitenoise sound. In alsamixer I can not see option for subwoofer only through gui sound settings and that was strange for me. But suddenly after few days my subwoofer started working so i was happy, but next day when I turned my notebook on an tried to use volume down button, sound is still at max velocity. In Gui sound setting appeared new soundcard and I must everytime change through settings, sound, choose a device for output for change a volume. When i plug earphones I need to do it again. Any ideas how to setup to work correctly?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.