1

I have bought one USB WIFI dongle by this name "EDUP":

(Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter)

so I have configured the file by this way:

# The loopback network interface
auto lo
iface lo inet loopback

#auto usb0
#iface usb0  inet static
#  adress 192.168.7.2
#  netmask 255.255.255.0
#  network 192.168.7.0
#  gateway 192.168.7.1
#  broadcast 192.168.7.255
# dns-nameservers 8.8.8.8 8.8.4.4

    #allow-hotplug wlp2s0
    #iface wlp2s0 inet dhcp

    auto wlan0
    allow-hotplug wlan0
    iface wlan0  inet dhcp
       wpa-ssid "roshd"
       wpa-psk "rr1393"

the output of ifconfig is :

usb0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.7.1  netmask 255.255.255.0  broadcast 192.168.7.255
        inet6 fe80::a383:7ee9:36f9:2027  prefixlen 64  scopeid 0x20<link>
        ether aa:70:b5:c0:6b:29  txqueuelen 1000  (Ethernet)
        RX packets 5062  bytes 347070 (338.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10323  bytes 9779116 (9.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet6 fe80::ea4e:6ff:fe64:fa65  prefixlen 64  scopeid 0x20<link>
        ether e8:4e:06:64:fa:65  txqueuelen 1000  (Ethernet)
        RX packets 61  bytes 6599 (6.4 KiB)
        RX errors 0  dropped 5  overruns 0  frame 0
        TX packets 22  bytes 3509 (3.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.1.108  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::9440:4b06:b605:ca01  prefixlen 64  scopeid 0x20<link>
        ether c8:3d:d4:3c:23:63  txqueuelen 1000  (Ethernet)
        RX packets 755893  bytes 988980144 (943.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 480126  bytes 53989884 (51.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

the lsusb output also is:

so@notebook:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 010: ID 0bda:0821 Realtek Semiconductor Corp. 
Bus 001 Device 009: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 008: ID 174f:2408 Syntek 
Bus 001 Device 044: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 042: ID 0525:a4a2 Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget
Bus 001 Device 027: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have run the apt-get update by this configuration this device dont show in my network panel in my (LINUX MINT LMDE), : enter image description here

but when i have removed this lines from my /etc/network/interfaces file the wireless icon show my USB DONGEL and it is working:

 auto wlan0
    allow-hotplug wlan0
    iface wlan0  inet dhcp
       wpa-ssid "roshd"
       wpa-psk "rr1393"

, but I want to configure it for my raspberry and I need to use the /etc/network/interfaces file.

SO what I must to do to configure it in /etc/network/interfaces file automatically?

UPDATE:

Now when i remove those line i also have not access to my USB Dongle as you can see:

enter image description here Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.