2

I'm trying to dual boot my PC which already has Windows 10 installed (in UEFI mode) with Ubuntu. I'm aware that I have to install Ubuntu in the UEFI mode in order to avoid the hassle later. I have followed the instructions precisely from the article Dual boot Win 10 with Ubuntu. As of now, I have done the following steps:

1. Created a live USB with bootable Ubuntu
2. Changed boot priority to USB HDD drive in boot menu
3. Disabled fast startup
4. Disabled secure boot from BIOS

I have also tried booting from USB option from within Windows itself either with PC Setting (like for UEFI) or pressing shift key while clicking on Restart as mentioned in the article. However, whenever my PC restarts, instead of showing me the options to install Ubuntu, I get an error

"System doesn't have any USB boot system. Please select other option in boot manager.".

I'm using Acer Spin 7 model with 4GB RAM, Core i7 processor and 256GB HDD. I couldn't find the solution of the specific problem as mine in the internet. Any help or suggestions would be highly appreciated. Thank you in advance.

  • I do not believe, that disabling 'Secure Boot' is still necessary for current Ubuntu. – Alex Stragies Jul 7 at 14:30
  • What program did you use? If it was Rufus, you set one of the settings wrong which made the USB not UEFI. – John Stoneman Jul 8 at 18:52
  • @JohnStoneman I used the Universal USB Installer to make the USB stick bootable. If I change the boot mode to Legacy then I'm able to boot in Ubuntu however not in UEFI mode. So how should I make the USB stick bootable in UEFI mode? – Abhishek Ejam Jul 9 at 1:50
1

When I had this issue, it was caused by accidentally changing the Partition Scheme to MBR instead of GPT.

Try creating the Ubuntu USB with Rufus, and make sure the Partition Scheme is set to GPT and the Target System is set to UEFI (non CSM).

enter image description here

  • Thanks for the solution mate. Somehow, I managed to follow exactly the same steps a day before by doing few research and was able to finally dual boot Ubuntu alongside Win 10. However, after restarting it got directly booted to Windows and I executed the command bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi from Administrator's command prompt in windows and afterwards everything worked perfectly. Anways, thanks for the support. Cheers!! – Abhishek Ejam Jul 11 at 12:13
0

Make sure to disable legacy mode or at least set priority to uefi mode in the "bios" config. The usb drive should have a efi folder on it. The partition table is not relevant, windows needs gpt to boot in efi mode, linux can boot in efi mode from either a mbr or gpt partition table. The filesystem of the drive should be fat32. You can also check, whether the boot and the esp flag are set on the partition.

  • When using Rufus, it does matter. – John Stoneman Jul 11 at 12:39
  • Ok, I haven't used rufus yet. I just extract the image contents to a fat32 usb drive and set the boot and esp flag of the partition. – gfrodo Jul 11 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.