2

I'm trying to make Kali Linux run under Virtualbox, with my Windows 10 PC. I recently bought a USB WIFI adapter (Realtek RTL8812au), and I'm trying to USB passthrough the adapter to my Kali VM.

Thing is, every tutorial has the same method, and it doesn't work for me. VirtualBox seems to pick it up for a second and then nothing happens.

So I installed the Virtualbox extension pack, made a USB filter for my adapter, then before starting the VM I unplug my WIFI adapter (which is the only one I have on my PC btw), I wait for the VM to start, login to Kali, and then replug it. Thing is, I hear the Windows USB on sound, but Windows doesn't use it for network (which is supposed to happen). Virtualbox's USB Icon flashed red once, then green, then the dot disappears and Kali doesn't detect any USB adapter.

I really don't understand why it is working for everybody, but not me ^^

I also have Connectify and the Realtek utility installed on my PC, and yes I tried with those two disabled and it doesn't work either.

Can anyone help me ?

Thanks !

  • did you have a look at forums.virtualbox.org/viewtopic.php?f=35&t=82639? . basically, you need to add the adapter to USB Devices, remove the adapter, start the VM and THEN INSERT the usb adapter. – Bart Jul 4 '19 at 9:16
  • It is exactly what i'm doing but it still doesn't work :/ – Nathan Dubuc Jul 4 '19 at 9:51
  • in “Devices” menu > “Network Adapters“, is the adapter listed if you choose attached to "Bridged adapter" instead of NAT? – Bart Jul 4 '19 at 10:13
  • Since I want my adapter to be directly detected by the guest, I disabled every network settings for that guest on Virtualbox settings. So I have nothing enabled in VB's "Network" settings – Nathan Dubuc Jul 4 '19 at 10:40
  • @NathanDubuc part of the issue with using a USB wireless adapter and a virtual machine is many times the host will not pass the device on in the way you want it to. You can certainly use a usb Wireless adapter for your network connection on the VM, the VM will just see it as an ethernet connection, not wireless. That is why user Bart is having you look under Network adapters. – kemotep Jul 5 '19 at 12:26
1

Perhaps the adapter presents one set of USB ID information when it needs firmware loaded, and another after loading the firmware? And so your Virtualbox USB filter applies only to the "before-firmware" case? Then Kali loads the firmware to the adapter, the adapter resets to activate the firmware, and then the filter won't match any more as the adapter is now presenting different ID.

If that's true, then you would either need two filters, or adjust your existing USB filter to be applicable for both situations.

0

By default linux machine’s ip address is different from the local machine. if you run

ifconfig

ip address does not belong to your local network.

Go to machine/settings/network, network is attached to NAT. switch to bridge adapter. down below choose your network interface which is most likely the first option. now u will be using host machine's wifi adapter.

if u plug in your wireless card you will see that option in the network interfaces drop down menu. i believe for your card u should reboot it. and then your card might be working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.