0


I have an Asus n552vw (Nvidia gtx960m+Intel HD graphics 530) with Debian 9.
I thought of installing the Nvidia Optimus drivers to increase battery life, without any result.

I followed the official guide (bumblebee + proprietary) but after login the system freezes and the fans run at max, of course the system is unusable.
Formatted and installed again Debian 9.
I've tried bumblebee+nouveau, same result.

I have tried many guides, same result (always with a fresh installation system)
I have tried to configuring Nvidia driver without bumblebee to work in Prime Sync Mode, but I don't arrive at the end of the configuration (i've followed this guide here on stackexchange)

I don't know how to solve
Thank you all for any help

IMPORTANT EDIT
I successfully installed bumblebee + nvidia proprietary on Debian 10 (buster).
I realized that the problem on Debian 9 was the Kernel version (4.9) which did not support well the architecture for Intel skylake CPUs and the Nvidia Maxwell (and of course all the newest architectures) Installing the new 4.19 kernel I think the steps are similar to the ones I ran on Debian 10 (maybe setting wayland as default display manager)

After a clean install of debian 10.
If it crashes on boot add this kernel boot options (works on my Asus, refeer to GitHub ) acpi_osi=! acpi_osi="Windows 2015".
Launch the terminal and:
sudo dpkg --add-architecture i386; sudo apt-get update; sudo apt-get install bumblebee-nvidia primus primus-libs:i386 libgl1-nvidia-glx:i386 mesa-utils

When finished, check this package sudo apt-get install libgl1-nvidia-glx:amd64
Modifiy the grub sudo nano /etc/default/grub adding at the line GRUB_CMDLINE_LINUX_DEFAULTthe acpi_osi=! acpi_osi="Windows 2015" save and update sudo update-grub.

Reboot and check if it works launching cat /proc/acpi/bbswitch, should give OFF (rightly, In fact, the PC is using the Intel video card). Open another terminal's window, launch optirun glxgears, in the other windows launch againcat /proc/acpi/bbswitch now should give ON (rightly the PC is using the nVidia card to start glxgears). To test better i used glxsphere which gave me 60 fps with the intel card and about 300fps with the nvidia card (optirun).
That's all.

I hope I have written clearly and to be useful to someone.

  • So from a fresh install of Debian you ran the commands listed here and it did not properly install the drivers/your system froze on reboot? – kemotep Jul 3 at 17:45
  • Yes. I install the drivers, reboot, I can log in to the system and it freezes before showing the desktop, and the fans start and run at maximum – Mr.Paolito Jul 3 at 19:53
  • Specifically, you installed the drivers from the Official Debian repository and they do not work? Here another relevant wiki page you should check out. I do not own any devices with an Nvidia graphics card because of their poor Linux support so I cannot confirm that these steps work but I have used the Debian wiki's advice for installing the proprietary Intel and AMD drivers before with great success. You should edit your question to include the exact steps you have tried to reach your issue. Thank you. – kemotep Jul 3 at 20:13
  • Thank you, I've tried now. But black screen after restart GDM (one of the last point of the guide) – Mr.Paolito Jul 4 at 7:49
  • I would either use a different distro such as Ubuntu or Manjaro or Pop!_OS which have better support for Nvidia out of the box or not use a computer with an Nvidia graphics card. I understand your frustration but Debian has a lot of issues with hardware that requires proprietary drivers. Its great if all of your hardware is directly supported by the open source drivers that ship with the Linux kernel. Make sure to follow the link to the Arch wiki to try those fixes as it says if you are having problems too. – kemotep Jul 5 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.