-1

I have one Linux LMDE on my Lenovo IdeaPad 310 laptop, so my internet by wifi work but with ethernet, cable don't work. some outputs are here:

so@notebook:~$ inxi -Fxz
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:    Host: notebook Kernel: 4.9.0-9-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 Desktop: Cinnamon 4.0.10 
           Distro: LMDE 3 Cindy base: Debian 9.3 stretch 
Machine:   Type: Laptop System: LENOVO product: 80TV v: Lenovo ideapad 310-15IKB serial: <filter> 
           Mobo: LENOVO model: Torronto 5C2 v: NO DPK serial: <filter> UEFI [Legacy]: LENOVO v: 3JCN26WW date: 03/07/2017 
Battery:   ID-1: BAT0 charge: 25.2 Wh condition: 25.5/30.0 Wh (85%) model: SMP L15M2PB3 status: Unknown 
CPU:       Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23232 
           Speed: 704 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 704 2: 703 3: 689 4: 707 
Graphics:  Device-1: Intel vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM108M [GeForce 920MX] vendor: Lenovo driver: nouveau v: kernel bus ID: 03:00.0 
           Display: x11 server: X.Org 1.19.2 driver: modesetting,nouveau unloaded: fbdev,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 13.0.6 direct render: Yes 
Audio:     Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.9.0-9-amd64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8168 v: 8.043.02-NAPI 
           port: 5000 bus ID: 01:00.0 
           IF: enp1s0 state: down mac: <filter> 
           Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtl8821ae v: kernel 
           port: 4000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           IF-ID-1: as0t0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-2: as0t1 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-3: as0t2 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-4: as0t3 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-5: as0t4 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-6: as0t5 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-7: as0t6 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-8: as0t7 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 1.82 TiB used: 582.02 GiB (31.2%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB temp: 35 C 
Partition: ID-1: / size: 196.17 GiB used: 18.39 GiB (9.4%) fs: ext4 dev: /dev/sda7 
           ID-2: /home size: 196.17 GiB used: 158.74 GiB (80.9%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 277 Uptime: 25m Memory: 11.64 GiB used: 4.17 GiB (35.8%) Init: systemd runlevel: 5 Compilers: 
           gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.32 

and

so@notebook:~$ ifconfig
enp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether c8:5b:76:8b:3e:ae  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 125  base 0x9000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 59905  bytes 3635977 (3.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 59905  bytes 3635977 (3.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.108  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::9440:4b06:b605:ca01  prefixlen 64  scopeid 0x20<link>
        ether c8:3d:d4:3c:23:63  txqueuelen 1000  (Ethernet)
        RX packets 9689  bytes 4781610 (4.5 MiB)
        RX errors 0  dropped 10  overruns 0  frame 0
        TX packets 5862  bytes 990587 (967.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

and I have run sudo apt-get install r8168-dkms my

/etc/network/interfaces file is:


# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d


# The loopback network interface
auto lo
iface lo inet loopback

allow-hotplug wlp2s0
#iface wlp2s0


#allow-hotplug enp1s0

#auto enp1s0
# iface enp1s0 inet dhcp

#https://askubuntu.com/questions/876631/ubuntu-server-16-04-static-ip-will-not-be-static
#auto enp1s0
#iface enp1s0 inet static
#        address 192.168.0.200
#        netmask 255.255.255.0
#        network 192.168.0.0
#        gateway 192.168.0.1
#        broadcast 192.168.0.255
#        dns-nameservers 192.168.0.1
#        dns-nameservers 8.8.8.8

when i have this setting for enp1s0 :

enter image description here

also, the internet doesn't work.

UPDATE: According to Soheil paper answer, I tried this scripts:

sudo dhclient  -r  #refreshed ip
sudo dhclient  # restarted ip

and get this output:

enter image description here

but when i disabled the Wifi connection i have not internet as you could see here: enter image description here

in this time i have:

so@notebook:~$ ifconfig 
enp1s0: flags=-28669<UP,BROADCAST,MULTICAST,DYNAMIC>  mtu 1500
        ether c8:5b:76:8b:3e:ae  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 125  base 0x9000  

enp1s0:avahi: flags=-28669<UP,BROADCAST,MULTICAST,DYNAMIC>  mtu 1500
        inet 169.254.8.71  netmask 255.255.0.0  broadcast 169.254.255.255
        ether c8:5b:76:8b:3e:ae  txqueuelen 1000  (Ethernet)
        device interrupt 125  base 0x9000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 831793  bytes 566001568 (539.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 831793  bytes 566001568 (539.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

So what can I do to solve this problem?

Thanks.

  • When I remove all comments in the configuration file you give, here's what's left: these 3 lines: auto lo , iface lo inet loopback, allow-hotplug wlp2s0. So is there an interest in giving this configuration in the question at all? Are you ultimately using it or is NetworkManager (or an other tool?) ignoring it? It can be misleading. Why not use DHCP as this is the most common case? – A.B Jul 3 at 9:25
  • really I am a newbie in Linux and really I don't know when I added these lines to that file, but if these are not necessary, so could be deleted. – modern Jul 3 at 19:03
0

According to this question do this:

https://tor.stackexchange.com/questions/10313/internet-only-works-with-tor-enabled

sudo dhclient  -r  #refreshed ip
sudo dhclient  # restarted ip
  • It shows but internet dont working – modern Jul 3 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.