1

I'm trying to replace the default Windows 10 installation with Linux on this hybrid tablet.

What I tried

First I tried with Ubuntu 18.04, blank screen, I thought about starting modifying the KMS settings but I read that Arch (and derivatives) are better supported so I ditched Ubuntu and moved over to Manjaro.

Manjaro didn't work out of the box and I immediately ran into a blank screen, so I started tinkering with the KMS settings, first I changed all the modesets to 0 (radeon, nouveau, i915) changing i915.modeset=1 to 0 helped me getting rid of the black screen in favor of garbled text on screen (same as nomodeset obviously), I also tried adding some other i915 options such as: i915.alpha_support=1, i915.enable_guc=3, etc.

At this point I realized that I might be dealing with some driver issues so I switched to the Intel customized Clear Linux which brought me to the same state again (Starting without any modification leads to blank screen, garbled with nomodeset).

So in order to make sure I'm not missing something I tried with Arch, exactly the same results.

Which flags did I use

In order to activate the basic framebuffer (I'm not sure about VESA) options I applied nomodeset and since the screen is rotated I had to use fbcon=rotate:1, these 2 options together resulted in a garbled text which is partially readable (this is how I know the text was rotated).

Additional KMS options I used but probably had no effect:

  • gfxmode=(various combinations), including switching between width and length
  • gfxpayload=text|vga|keep

Even if there was a slight change it's very hard to notice.

Lenovo D330 has several models, from what I figured the model I'm using is Miix D330-10igm 81h3 (As written on the bottom of it, where the keyboard connector is).

The graphics card is presumably Intel UHD 630 (which is the reason I tried enabling GUC in the first place and having all the tests with Clear Linux).

I'm not sure what else should I try and whether I'm looking at the right KMS options and settings.

Image showing the garbled display after logging

Supposed to be the initial Arch prompt: Garbled/distorted display after trying the KMS options I mentioned

  • Surprisingly the low graphics mode in Ubuntu shows the same results as what I achieved through tinkering, sadly I still can't get it to work :( – Yaron Jul 3 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.