2

I frequently suspend and resume Vim with ctrl-z and fg, respectively. In all the OS/Terminal combinations I've used, whatever they were, the behavior was I would see whatever was on the screen before starting Vim.

At work, I've recently been moved to a newer CentOs host for the development work I do (no Internet access).

Now, suspending puts the cursor at the bottom of the screen, leaving the lines from the Vim session above it. I'd like to change back to the behavior I've become accustomed to -- how do I control this behavior? Not sure what information is needed (I'm not good at configuring vim...). It's a newer version of CentOS (probably 5, previously 4) and bash.

  • 3
    That has nothing with do with vim, but with whether your terminal emulator supports the smcup/rmcup escapes and whether they're enabled and "published" in the terminfo database. They're not supported in the linux console. AFAIK vim will always use them if available. Add info about what terminal you're using together with the output of infocmp run inside it. – mosvy Jul 2 at 12:43
  • 3
    A program where they're are disabled by default is the screen terminal multiplexer. If you're using it, adding altscreen on in your ~/.screenrc should re-enable it. – mosvy Jul 2 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.